SRW2024P web front end lost after installing firmware 1.2.9

Unanswered Question
Oct 13th, 2009

Hi,

I own a SRW2024P switch. I installed the latest available firmware and now the web front end is lost. It just shows an empty web page without any additional information, not even the login prompt. I tried the https alternative without luck either (it sends the certificate correctly, but only an empty page is presented, without any login prompt).

The telnet interface is working properly.

I tried to flash the firmware again, with the same results.

Any ideas?

Costa

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tiya Rabb Thu, 10/15/2009 - 09:56

What browser(s) are you using when attempting to access GUI?

In the meantime, try changing the username from admin to something else, e.g. admin1. Then try to log on with new username.

CostaTsaousis Tue, 10/20/2009 - 00:25

Thanks for the assistance.

In firefox it presents an empty page (no login prompt or anything else).

In i.e it gives a dialog that the current page is willing to close the window (strange - this happens on the main window, not a popup).

I changed the usernames and passwords. No luck.

I restored to factory defaults. No luck again.

Any other ideas?

Costa

Tiya Rabb Thu, 10/22/2009 - 10:28

In i.e it gives a dialog that the current page is willing to close the window (strange - this happens on the main window, not a popup).

This is very interesting. What version(s) of IE is this? Just as a test, from the console menu, try changing the port number for the HTTP server of the switch, a random port number i.e. 15754. If this change allows GUI access,  I would recommend flashing the firmware (once more), then directly after complete boot, reset to factory defaults, then manually reconfigure. I look forward to your response.

Message was edited by: Tiya Rabb

CostaTsaousis Sun, 10/25/2009 - 14:22

I tested internet explorer 8 and firefox 3.0.14.

Changing the HTTP port has no effect (in IE it requests to close the window, in firefox does nothing).

I also tried to wget the url. This is what it produces:

window.close();

Any other ideas?

CostaTsaousis Mon, 10/26/2009 - 12:53

I did follow the MS fix, without any changes in the results.

The switch web front end is still unusable...

jamccord Mon, 10/26/2009 - 13:04

Hello,

It is not uncommon to have to restart your computer and the switch several times before it will work properly after the MS fix is applied.

Please reboot both devices a couple of times after trying to log into the switch interface.   Let me know what you find.


Jason

CostaTsaousis Mon, 11/09/2009 - 04:01

Well, I did several reboots on both devices without any progress.

Actually, I believe the windows reboots are useless, since, as I said before, the switch returns an html page with just a javascript close window statement. There is nothing to be done on the web browser side to change that.

Do you suggest going back to the previous firmware?

jamccord Mon, 11/09/2009 - 06:12

Hello Costa,

I would suggest that you call the Cisco Small Business Center at 1.866.606.1866 and speak with one of the engineers.  The center is open 24/7/365 for your convenience.

We typically do not support going backwards in firmware, but it may be worth a shot to see if the firmware downgrade will allow you into the webui.

After that, reapply the new firmware and test again.   Remember to reset the switch to factory defaults too.

Jason

robert.delien Thu, 03/03/2011 - 05:09

I have the exact same problem. Calling Cisco isn't of any help: They simply hide behind barricades of contracts and lengthy procedures. Now that's something to keep in mind next time I need network equipment.

Anyway, I'm 'happy' to see I'm not to only one with this problem. I have tried the same suggestions, but to no avail. Are there any solutions to this problem yet? Otherwise I will just send it in for repair because it's still covered by warranty.

David Carr Thu, 03/03/2011 - 06:52

Mr. Delien,


What browser are you using to access the switches gui?


If your using Internet Explorer try these steps.


Go to tools/ internet options/ security/ Custom Level.


Then at that screen scroll down to the activex Controls and plugins make sure all the options are enabled or prompt all the way to Script Activex controls marked safe for scripting*.


If using Firefox, you can get the addon named IE tab2 and click the firefox symbol in the lower right hand corner of the page and it will emulate an internet explorer page in firefox.

CostaTsaousis Thu, 03/03/2011 - 08:21

Hi all,

As I have said before, the switch returns an html page with just a javascript window close statement. You cannot do anything on the web client to change that.

The solution for me was to downgrade the firmware.

Regards,

Costa

CostaTsaousis Wed, 03/16/2011 - 10:20

Hi all,

well I used the really excellent Cisco service and replaced my switch with another one. Really impressed by the very fast response of all involved parties.

However, guess what: Once I upgraded to 1.2.9, the problem appears to this one (the new one) too.

I think I found the problem though. It only happens if you access the switch with a hostname. If you access it with an IP address it responds correctly.

Also, even with the hostname, try to get this url: http://hostname-of-your-switch/config/login.htm With this url, the web front end works as it should.

So, to my understanding there is a bug in firmware 1.2.9 where if you access the switch with a hostname, you cannot get to the login screen. The switch, instead of redirecting you to /config/login.htm, it sends back a page with a javascript statement to close the page.

Regards,

Costa

robert.delien Wed, 03/16/2011 - 14:08

I was literally about to unplug my switch and replace it with the replacement that arrived today when the notification of your post came in. So I re-upgraded my old one to 1.2.9 and tried your discovery: I can confirm that the web front end of my switch too is accessible using just the IP address. That's rather sloppy. Now it didn't make much sense anymore to replace the switch.

But I had a couple of LACP problems too, so I decided to switch anyway. The replacement still came with the old firmware, so I upgraded and again I got the same problem. But again using just the IP address worked. I guess this is something to go into the knowledge base.

I'm hoping for a fix, but I'm not really counting on it after this machine going EOL.

robert.delien Fri, 03/04/2011 - 02:53

Costa: Your wget was a real good one. Viewing the page source in explorer reveals the same page content and it's identical to what you have already posted, a java script command to close the page.

I have just spend my morning online chatting with Cisco support and I have to get back at my earlier remark on their service. For products like this you have to contact Small Business Support. That's something Big Business Support could have told me too, but they're forgiven.

Of course I had to go through the whole script of trying different browsers, editing the registry on my server (!) etc. The WebEx application crashed, so I had to go thought it three times, but the guys are skillful and helpful. They even tried to reproduce our problem on a machine in their lab. Very good. The last guy eventually suggested that this new firmware may not be fully compatible with my hardware revision, or that something is just broken.

Cisco doesn't recommend firmware downgrades and they didn't recommend me to use the switch in that state. Instead they offered me to replace it. And the best thing is: They will replace it in advance. My whole network depends on this switch, so I am really helped out here.

These switched come with a 5 year warranty, and they're not on the market for 5 years yet, so your switch is probably covered by warranty too. So I recommend you to make use of Cisco's excellent service too.

robert.delien Thu, 03/03/2011 - 10:14

I'm sorry, but as somebody here has already explained, it's not a browser problem. I have tried both Internet Explorer 8 and Firefox 5 on my SBS2008 server. I have also tried Safari 5 on my MacBook. None of those work, it's not a browser problem.

IE8 on my server worked just fine with the old firmware. Safari 5 did not and Firefox support was rather poor. (On a side note: Does anybody else see the irony in the worlds largest network equipment supplier being picky about the web browser used?)

Anyway, just to rule out the browser, I too have tried the Unix wget command on the switch' IP address and I too got the HTML command to close the browser window.

robert.delien Thu, 03/03/2011 - 10:24

Ok, it's definitely a firmware problem: I have just reverted back to version 1.0.4 using the icky telnet interface and the web front end is accessible again. But this leaves my switch in an unsupported state, so what should it do? It came with a 5 year warranty, so technically I could return it.

David Carr Mon, 03/07/2011 - 05:39

Robert,


The issue your seeing is a browser issue.  The switch is designed to support IE5 to 7.  Unfortunately for those switches IE8 does not work well with them.  However the IEtab2 add-on for Firefox is works just fine for people not running Windows platforms or they have IE8 on the box.


The new sf/sg300 series switches that Cisco has come out with is supported on both firefox and internet explorer browsers.


If you could try a machine with IE7 as the browser with the latest firmware and you shouldn't have any issues with it.

robert.delien Mon, 03/07/2011 - 07:03

It cannot be a browser issue, because when I look at the page's source code it look like this:

window.close();

However, your firmware can repond differently to different browsers and as a result attempt to close my browser window if an 'unsupported' browser is used. Besided the question wheter you can force your customers to use a deprecated version of a single browser, would showing a warning about an incompatible browser still be preferable above blunlty closing the browser window...

Actions

This Discussion