Question about EIGRP summary route and its Leak-Map

Unanswered Question
Oct 13th, 2009
User Badges:

I have two sites A and B as the following:


MPLS WAN MPLS WAN

| |

| |

Site A ------------ Site B


Site A routing: OSPF area 1 internally, OSPF area 0 with Site B. EIGRP into WAN.


Site B routing: OSPF area 2 internally, OSPF area 0 with Site A. EIGRP into WAN.


Routing requirement is WAN as the primary route for A to reach B and vice versa, and the backdoor link as backup.


Both sites have OSPF intra-area and external routes. When those routes are redistributed into EIGRP, they become EIGPR external routes when received by the other site. EIGRP external has higher administrative distance than OSPF routes via the backdoor link.


I have tried EIGRP summary routes and OSPF inter-area summarization. But the problem is OSPF "area range" command don't handle A or B's OSPF external routes. I'm thinking about the following two tricks. Can someone tell me if it works?


Option 1: if site A has an OSPF External route as 10.20.1.0/24, the route will be redistributed into EIGRP to be sent into WAN. I can add a EIGRP summary route as itself. Because EIGRP summary route is carried as administrative distance 90, this make site B prefers the route coming from WAN over the OSPF from backdoor link.


Site A#

interface <WAN>

ip summary-address eigrp 1 10.20.1.0 255.255.255.0


Can a route be summarized to itself?


Option 2: use Leak-map in EIGRP summary route configuration to let 10.20.1.0/24 leak into the WAN cloud:


Site A#

interface <WAN>

ip summary-address eigrp 1 10.20.0.0 255.255.254.0 leak-map OSPF-External


route-map OSPF-External permit 10

match ip address 10


access-list 10 permit 10.20.1.0 0.0.0.255


Is the leaked router still carried as administrative distance 90?


Thanks a lot for any help



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marwan ALshawi Tue, 10/13/2009 - 21:41
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i would say don't use summary routing

the best option for your case is the use of distance command


in bothe rWAN router add the following caommand under ospf process


distance ospf external 171


this way all the EIGRP external route will be prefered over OSPF external routes becuase now ospf external route AD will be 171 which is higher than external eigrp 170


good luck

if helpful Rate

gwhuang5398 Wed, 10/14/2009 - 06:46
User Badges:

I can't use "distance" command because I also have a default route as OSPF external route. The primary default route need to stay local, not from the WAN. "distance" command changes all external routes.


Thanks

Marwan ALshawi Wed, 10/14/2009 - 13:08
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

in this case do it like this


ip prefix-list list1 deny 0.0.0.0/0

ip prefix-list list1 permit 0.0.0.0/0 le 32


route-map map1

match ip address prefix list1


router ospf 1

distance ospf exxternal 171


router eigrp [as number]

redistribute ospf 1 metris 1 1 1 1 1 route-map map1


in this way you will still use the distance comand and prefer external eigrp over your WAN link

and at the same time you filter out the default route from being redistributed from ospf to eigrp

this will keep the default route local to ospf only as you want


good luck



Marwan ALshawi Thu, 10/15/2009 - 15:36
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

have you tried the solution i have given above ?

Actions

This Discussion