Server Teaming - 4NIC

Answered Question
Oct 14th, 2009
User Badges:

Server with 4NIC needs to connect to L3switch as a single pipe for redundancy and high throughput


Server has a teaming software to combine all these interfaces as one.


What config is required on Switch.


Currently the server is connected with one NIC to switch

Server IP : 192.168.1.10/24

Switch : giga 0/21

switchport mode access

switchport access vlan 9

speed 1000


Correct Answer by Giuseppe Larosa about 7 years 8 months ago

Hello Amin,

to build a L2 etherchannel that is not a L2 trunk


int giga0/5

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int giga0/6

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int giga0/10

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int giga0/11

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int po5

no shut


! this can be needed on some switch

! platforms for example C6500


to avoid problems with starting up the member links one possible solution is to start with all member links shut


and then to use interface range to make an unshut in sync.


interface range gibabitethernet 0/5 - 6, 0/10 - 11

no shut


! pay attentions to spaces that are required

! or interface range is not accepted


then depending on platform you may need to unshut the bundle interface po5 in this example.


Do this when server NICs are configured to use LACP


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rc.castillo Wed, 10/14/2009 - 23:15
User Badges:

Hi,


You can use etherchanneling on the switch ports.


i.e.

interface port-channel1

switchport mode access

switchport access vlan 9

spanning-tree portfast


interface range g0/21-24

channel group 1 mode active

switchport mode access

switchport access vlan 9

spanning-tree portfast



Giuseppe Larosa Wed, 10/14/2009 - 23:24
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Amin,

if all 4 NICs are active that is it is an active/active teaming you can only use an etherchannel bundle.


I recommend to use LACP IEEE 802.1ad on the switch side you prepare all the 4 NICs like the one already connected


int gi x/y

switchport

switchport mode access

switchport access vlan 9

speed 1000

duplex full


to setup an LACP bundle add to each interface:


channel-group x mode active


x is a number of an unused bundle.


for example x= 5


you may need also


int po5

no shut




you can check current etherchannels with


show etherchannel summmary


the server NICs have to be configured for LACP to send LACP messages on each port.

if the switch port fails to hear LACP message for some time (90 seconds) the port is removed from bundle.


This provides control of what is happening and has to be preferred to unconditionally bundling (channel-group y mode on)


refer to server documentation on how to setup an LACP bundle.


we are using this for all new servers.


Hope to help

Giuseppe


Amin Shaikh Thu, 10/15/2009 - 12:49
User Badges:

Hi Giuseppe,


I didnt understand the Etherchannel configuration.


Assume Server 4NIC interface on Switch are connected to switch ports

giga0/5

giga0/6

giga0/10

giga0/11


what config needed on these interfaces.


Correct Answer
Giuseppe Larosa Thu, 10/15/2009 - 23:36
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Amin,

to build a L2 etherchannel that is not a L2 trunk


int giga0/5

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int giga0/6

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int giga0/10

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int giga0/11

switchport

switchport mode access

switchport access vlan 9

channe-group 5 mode active

speed 1000

duplex full


int po5

no shut


! this can be needed on some switch

! platforms for example C6500


to avoid problems with starting up the member links one possible solution is to start with all member links shut


and then to use interface range to make an unshut in sync.


interface range gibabitethernet 0/5 - 6, 0/10 - 11

no shut


! pay attentions to spaces that are required

! or interface range is not accepted


then depending on platform you may need to unshut the bundle interface po5 in this example.


Do this when server NICs are configured to use LACP


Hope to help

Giuseppe


Actions

This Discussion