Extension Mobility not working

Answered Question
Oct 15th, 2009
User Badges:

Hi,


I have a CUCM running 6.1(2)SU1a.


I configured EM accordingly but when I access EM service on the IP Phone I get the following error:


[2]-Cannot auth. App user


If I force an error in the PIN (intentionally input an invalid PIN) I get the following error:

[201]-Authentication error


I also noticed that if I either check or uncheck the Enable Extension Mobility checkbox on the Device Configuration Page the behavior is still the same which, somehow, leads me to think that the application is not running properly.


I already restarted the CUCM box, the Cisco Tomcat service from CLI to no avail.


What am I missing here?


Best regards,

Pedro Marques

Correct Answer by Jaime Valencia about 7 years 6 months ago

Try resetting the CCMSysUser pwd and reset tomcat, then try again


HTH


java


if this helps, please rate


www.cisco.com/go/pdihelpdesk

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
stowellp Thu, 10/15/2009 - 07:39
User Badges:
  • Bronze, 100 points or more

Hi Pedro,


Have you done all of the following?


Step 1 Activate the Cisco Extension Mobility service in CUCM for the cluster.


Step 2 Set Cisco Extension Mobility service parameters.


Step 3 Add the Cisco Extension Mobility phone service.


Step 4 Create default device profiles for all phone models used.


Step 5 Create device profiles, and subscribe them to the Cisco Extension Mobility phone service.


Step 6 Create end users, and associate them with device profiles.


Step 7 Enable Extension Mobility for phones, and subscribe the phones to the Cisco Extension Mobility service.


Cheers,

Phil


pmarques Thu, 10/15/2009 - 07:57
User Badges:

Hi Phil,


Yes I did all that. Several times.


Still getting the same error.


Cheers,

Pedro

pmarques Thu, 10/15/2009 - 08:24
User Badges:

Hi java,


Before posting I saw you recommendations.


As per the Cisco Tomcat restart, as stated in my original post, I already did that.


As per the CCMSysUser reset, as this is a 6.x CUCM, and after searching a lot I did not find a way to do that on this Linux based servers.


I found the way of doing that only for version 4.x and early.


Didn't even know it was possible to do this in 6.x version.


regards,


Pedro

sshams007 Thu, 10/15/2009 - 09:56
User Badges:

Hi pedro,


I guess this issue relates to the credentials like your username and PIN. Look out for the Upper case and lowercase of your username.


Firstly:If you are logging into the Extension mobility for the first time ensure you key in the default CUCM pin for the end user to log into extension mobility. Check your end user credential policy on CUCM.


As a second option can you delete the Enduser(only if LDAP sync is not active) and recreate it again. If you cannot delete the end user because of LDAP sync then try creating a new end user and then try Extension mobility with that user.I faced a similar problem some time back and i was able to get rid of it by creating a new user and then re configuring the whole stuff again.


Last thing i wanted to check is, have you enabled Extension Mobility on Device configuration page for the Phone. Also ensure the Em service is subscribed for both the Device and Device profile.


Thanks

Sandeep

William Bell Thu, 10/15/2009 - 10:54
User Badges:
  • Purple, 4500 points or more

Pedro,


I am not sure that CCMSysUser is the issue but it is possible given the context clues in your error message:


[2]-Cannot auth. App user


"App user" means "application user"


I assume you checked all of the obvious things like user-profile assignment, service assignment, and making sure that the "EM Enabled" option is configured on the device.


CCMSysUser is an application user and you can manage the user in CUCM by going to User Management>Application User. Click on find and you will see CCMSysUser.


You will want to check that this user is a member of:


"Standard CTI Allow Control of All Devices" and

"Standard EM Authentication Proxy Rights"


I would also check the Security syslog. If there is an authentication error happening related to CCMSysUser it will pop up there.


I can't imagine how the password would get fowled up with CCMSysUser, but if it did I suppose you can reset the password on the Application User and test.


HTH


Bill (http://www.netcraftsmen.net/resources/blogs/blogger/William%20Bell/)

pmarques Fri, 10/16/2009 - 00:49
User Badges:

Hi Bill,


Thanks for your support.


Yes, the culprit was the CCMSysUser.


A simple reset (which, until now I didn't know how to do) solved the problem.


Cheers,

Pedro

Actions

This Discussion