UCCX 7.0.1SR4 and Presence issue

Unanswered Question
Oct 15th, 2009

Hi

I have configured the presence AXL user to that of my cups username and everything validates okay. My CUPC client works fine and can view all contacts so the LDAP profile is correct.

However, when I try to search for contacts within CDA I recieve the message

CDAUI2067 Search did not complete successfully, and only partial results are displayed. Contact technical support.

I have taken a wireshark trace of the LDAP transaction between UCCX and LDAP server and the response is fine with correct response i.e. valid search yet the application errors.

Anyone had similar issues

Paul

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
atalante Thu, 10/15/2009 - 08:08

Hi Paul,

I don't have CUPC and and I'm not able to help you. Do you have the same issue with CSD ?

Would you like please, to make test for me.

I planned to install the SR4, but I need to check that the SR4 resolved an issue on historical report. The report is agent summary, on which filter by team are not working properly.

thanks for your help.

mnathlic Thu, 10/15/2009 - 08:32

I have seen this issue in the past, usually releated to DNS. If a stand alone UCCX server you may try a static entry in the Hosts file.

Mike

plearmouth Thu, 10/15/2009 - 23:34

Mike

A static entry pointing to where ? Remember I can see a correct response from the LDAP server but still the error - so I know it can resolve the LDAP server address from the profile

thanks in advance.

Paul

atalante Fri, 10/16/2009 - 00:39

Problem When searching for subject matter experts from the Contact List page,

no names are found, and this error message appears: “CDAUI2067

search did not complete successfully, and only partial results are

displayed. Contact technical support.”

Solution This error occurs when the parameters on the Unified Presence Cluster

Settings page are not configured correctly. There are two possible

causes of this problem: the user credentials are incorrect or the

hostname/IP address is incorrect.

NOTE: The user specified on the Cisco Unified Presence Cluster

Settings page must be able to perform SOAP queries and must

be associated with the same profile in LDAP that agents are

associated with.

To diagnose and resolve the problem, complete the following steps.

1. Choose Cisco Unified Presence Settings > Cisco Unified Presence

Cluster Settings.

Desktop Administrator Problems

April 2009 85

2. Click Verify.

■ If the hostname/IP address are incorrect, this error message

appears: “CDAUI2033 Error communicating with the Unified

Presence Server.”

■ If the user credentials are incorrect, this error message

appears: “CDAUI2034 Invalid Cisco Unified Presence Cluster

user credentials. Configured user must be able to run SOAP

queries.”

3. Type the correct information in the appropriate fields, then click

Verify to test the information you just entered. A message should

appear, stating that the transaction was successful.

4. Click Save.

plearmouth Fri, 10/16/2009 - 07:31

Sorry - I think you mis-understood what I meant to say I had already seen this document and although the validation succeeds the problem still exists.

i.e. it still doesn't work

Jonathan Schulenberg Tue, 11/10/2009 - 08:20

There is an undocumented configuration requirement that will cause this (imagine that).

The user you configure in CDA must be a licensed and fully configured END USER in CUPS, not an application user.

plearmouth Wed, 11/11/2009 - 02:59

Chris,

Its been a TAC case now for a couple of weeks without resolution. I will post a message once 'resolved'

regards

Paul

justincohen Wed, 12/02/2009 - 08:18

Add me to the list.

I can create groups but not add anyone, the user account is right.

myquick6 Mon, 07/12/2010 - 10:03

Did anyone ever get an answer for this issue.  I have two installs and I have the same error on both

.

Thanks, JR

plearmouth Wed, 07/14/2010 - 03:12

Hi JR

Apologies I thought I had posted the outcome !

TAC Webex'd onto UCCX and confirmed the problem. Then the following excerpt 'taken from the TAC case'

- Created new ldap profile
- selected only primary ldap server
- bind it to the user (CUPS admin, APplication/CUPC/User Settings)
- it worked

- changed back to original profile
- worked again

- included secondary ldap server as well under the profile
- worked again

- so basically, latest config is the original starting point when it was not working but
now it is working without any restarts being performed in the system, but only the changes
listed above in that order.

Essentially, TAC confirmed the issue, then it went away simply by creating a second Profile then reverting back to mine. Not an ideal answer but its working.

Paul

mwheinz Wed, 11/30/2011 - 07:21

I have an install with this same problem, version 8.5 UCCX, 8.6 CUCM, 8.54 CUPS.  Has anyone resolved this issue?  TAC has not been helpful and we engaged Calabrio to no avail.

Everything else works fine, CUC Single Inbox, CUPC, CUCM AD sync, all is well except this one "feature".

Any suggestions on how to proceed will be appreciated.

Thanks!

Mike

Actions

This Discussion