FWM flash problem

Unanswered Question
Oct 15th, 2009
User Badges:

Hi,


I have an WS-SVC-FWM-1 and I'm getting the following problem. When I try to the save the configuration I get this error: Buffering file....Insufficient flash space available for this request:

Size info: request:60504 current:60504 delta:0 free:10567724

Could not open file to write

60504 bytes copied in 0.560 secsInsufficient flash space available for this request:

Size info: request:41 current:41 delta:0 free:10567724

open(ffsdev/2/write/41) failed


dir flash:

Directory of flash:/


2 -rw- 4153392 <no date> asdm

1 -rw- 5898752 <no date> image

3 -rw- 60504 <no date> startup-config

No space information available.


Has anyone had a similar situation?


Thank you.


Best regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
Yudong Wu Thu, 10/15/2009 - 14:15
User Badges:
  • Gold, 750 points or more

Flash header might be corrupted.

You can try:

1. "clear flashfs" then "wr mem"

2. If step 1 won't work, backup your current config. Then "format flash:" and then run "fsch flash:". Then reinstall image and copy the config back.


If you are not feel comfortable about the above steps, open a TAC case for help.



Norberto Salgado Fri, 10/16/2009 - 03:27
User Badges:

Hi,


thank you for your reply.

The clear flashfs don't imply any disruption of service correct?

Yudong Wu Fri, 10/16/2009 - 09:25
User Badges:
  • Gold, 750 points or more

No, it should not impact the service.

This command just clear the flash header. When you issue "wr mem", flash header should be rebuilt.


But, I would like to suggest to do it in a maintenance window just in case.

Panos Kampanakis Thu, 10/15/2009 - 14:58
User Badges:
  • Cisco Employee,

This could be different things:

- it could be caused by ACL optimization if you have enabled it in FWSM 4.0

- it could be a corrupt flash that could be fixed after formatting it. If you format you will need to copy the sw images to flash and save the configs again

- It could be a corrupt flash due to a hw problem.


PK


tomyjoseph17 Tue, 10/04/2011 - 11:17
User Badges:

Hi Norberto Salgado,


How did you get this problem fixed , I am also facing the same issue in my FWSM. Any help is much appreciated.


Cisco TAC says its a problem with flash and needs format. But I face the problem in both primary and secondary FWSM running in active/standby mode. I am wondering how flash in both units can go faulty togethor ?


Regards

Tomy 

tomyjoseph17 Wed, 10/05/2011 - 04:54
User Badges:

Hi Norberto Salgado,


Please help , I am waiting for your valuable inputs on this ..


Regards

Tomy

Norberto Salgado Thu, 10/06/2011 - 01:46
User Badges:

Hello Tomy,


I'm sorry for my late answer. In our case it was bad CF, we tried the format but without any results.


It's strange that you have the same issue in the primary and secondary. But if it's a corruption, maybe during the sync also corrupted the secondary? Anyway it would be strange because the only that it's sync it's the config...


You already tried the format?


Best regards,


Norberto

tomyjoseph17 Thu, 10/06/2011 - 03:18
User Badges:

Thanks Norberto..


I think my problem would be due to space availability on flash.


Directory of flash:/

2      -rw-  12645692            asdm
1      -rw-  6423040             image
3      -rw-  1737411             startup-config


Flash is 20 MB.


ASDM file have 12.05 MB size

Image is 6.12 MB

Starup-config is 1.65


Total space used is 19.84 MB in flash. And my current ruuning configuration file is 2.89 MB .


I think this is why I am unable to save the configuration . I will get some space if I delete the asdm image which we are not using , but my vendor says fwsm is having a limitation that asdm image cannot be deleted.


Any lights on this ?


Regards

Tomy

Norberto Salgado Thu, 10/06/2011 - 03:31
User Badges:

Hi again,




I think that your vendor it's correct, you can't delete the asdm. But if you're not using it you probably can replace it with an older version that will need less space.




BR

Actions

This Discussion