SGE 2000 - DHCP Relay

Unanswered Question
Oct 16th, 2009

Hello Community,

I have definded several VLANs and the coresponding IP Adresses on the SGE2000. The static routing works fine. On one VLAN there is a Windows 2003 DHCP Server which I have defined as DHCP Relay Server (Option 82), but no packets are relayied. Has anyone a functional setup, with dhcp relay?

Thanks in advance,

Jan Jensen

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
alissitz Fri, 10/16/2009 - 20:16

Hello and Good Evening,

Assuming you have the DHCP scopes set up correctly, you will need to enable DHCP relay and enter the IP address.  By default broadcasts (DHCP requests) do not get forwarded past L3 boundaries.  The relay feature will address this.  

I have a similar set up and this works fine.  Do please let me know how you make out.  Kindest regards,

Andrew Lee Lissitz

David Hornstein Fri, 10/16/2009 - 22:26

Hi Jan,

firstly , I checked today and saw that the new release of code is available at the support > downloads section of

Looks like is available to download.  You will, I believe need a cisco login to grab that new file.

I found that when i tried to download software  via  the SGE2000 product info page, which is usually another way to get code, only the older software could be downloaded.  That i guess will take a few days to change


try this new software first, I must admit i did not check the release notes regarding DHCP relay, but upgrading software is the quickest thing to try.

But, you still may just have a configuration issue, if you  check the built in help text on the DHCP relay, it mentions, to enable DHCP snooping on the VLAN you are on.

You have a couple of actions to take, does the problem still exist or does DHCP relay now work to the Windows server ?

If your issue  still exists contact the Small Business Support Center via the following URL;

regards Dave

Kasi Viswanathan Sun, 11/25/2012 - 09:16


I have the same issue in relaying a DHCP with SGE2000, but the only difference is my DHCP Server is a Linux box.

When the DHCP Server and the Client are in the same VLAN, the communication works fine as expected.

But across VLAN's, the DHCP Discover  broadcast is not reaching the server.

Have enabled ip helper, DHCP relay and DHCP options on the SGE2000, but still doesnt seem to go through.

Updated the software version of the SGE2000 to the latest firmware but still doesn't work,

I can paste the configuration details if needed.

Should DHCP Snooping be enabled for this setup to work?


Kasi VPS

Tom Watts Sun, 11/25/2012 - 10:16

Hi Kasim

DHCP option 82 only works if the DHCP snooping is enabled. If the DHCP is not working, you may have to add a route on the DHCP server.

Please rate helpful posts

Kasi Viswanathan Mon, 11/26/2012 - 07:52

Hi Thomas,

Could please let me know what route should be in place?

Since we are in the deployment stage, we just created 2 VLANs, VLAN 10 & VLAN 20.

DHCP Server in part of VLAN 1 (DHCP Server IP :

Switch Management IP:

Client computers from VLAN 20 are not getting an IP from the DHCP Server.

VLAN 20 IP :

VLAN 20 Client IP Address range defined in DHCP Scope: 172.16.2.x

IP helper address is pointed to the DHCP server,but the DHCP broadcast traffic is not hitting the DHCP server in the log messages.

What could be the issue?


Kasi Viswanathan

Tom Watts Mon, 11/26/2012 - 08:42

The issue is the broadcast is going out of the server but not coming back to the server.

To add a route on your DHCP server, this is something you need to contact the server admin for.

Here would be an example for server 2003...

Route ADD Mask –p

If you have the dhcp relay / iphelper set up correctly, you may want to contact the server's support team / admin as the switch won't do any thing more.

Please rate helpful posts

Kasi Viswanathan Mon, 11/26/2012 - 09:01

Thanks for the quick response.

I meant the client's DHCP DISCOVER broadcast packet is not coming to the DHCP Server.

As far as i understand, the below process happens on a DHCP. Please correct if i m wrong.

Discover: The DHCP Client sends a Broadcast to the network discovering if there a DHCP Server.

Offer: The available DHCP server responds with the Offer

Request: The DHCP Client then request's the offer'd

Acknowledge: The DHCP then sends an acknowledgement to the client and confirms the leased IP address to it.

In our setup the Discover broad cast from the DHCP client from one VLAN(20) is not coming to the DHCP Server located in VLAN 1.

I also will try adding the route on the DHCP server provided by you and post the results.


Kasi Viswanathan

Kasi Viswanathan Tue, 12/25/2012 - 07:21


I tried configuring the route on the DHCP Server like below

route add -net netmask gw is my client network at VLAN 20 is my DHCP Server(Linux VM)

It still doesnt work. Please help where is something wrong.

The DHCP Server is able to lease IP to the clients on the same VLAN but not across VLAN's

Please find my running-config on the CISCO SGE2000

vlan database

vlan 10,20


interface ethernet 1/g15

switchport access vlan 10


interface ethernet 1/g3

switchport access vlan 20


interface vlan 10

name 172-16-3


interface vlan 20

name 172-16-4


interface vlan 1

ip address


interface vlan 10

ip address


interface vlan 20

ip address


ip route

ip dhcp relay address

ip dhcp relay enable

ip helper-address 37 42 49 53 137 138

ip helper-address 37 42 49 53 137 138

ip helper-address all 37 42 49 53 137 138


Kasi Viswanathan


This Discussion