Multicast setup 3560 E

Unanswered Question
Oct 16th, 2009

Hi Guys,

I am trying to configure multicast on a 3560E.

I normal just set the defualt "multicast routing" then add "ip pim sparse-mode" to l3 interfaces.??

However I only have the option on "ip multicast routing distributed" and ip pim passive on the vlan interfaces??

i am running universal code latest revision.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Reza Sharifi Fri, 10/16/2009 - 04:29

Hi Scott,

According to the config guide, it looks like distributed is the only option when enabling multicast on 3560s

As for PIM, you should be able to add PIM to the interface without passive option

Switch(config)# interface gigabitethernet0/2

Switch(config-if)# ip address

Switch(config-if)# ip pim sparse-dense-mode



scott-goodwin Fri, 10/16/2009 - 04:59

Hi Reza,

Thanks for the reply;

When I try add pim sparse mode i don't have any option apart from passive?? Can be seen below?

gw-mmu-halls-01(config-if)#ip pim ?

passive Enable PIM passive interface operation

gw-mmu-halls-01(config-if)#ip pim



Edison Ortiz Fri, 10/16/2009 - 05:02

It sounds like you are running 'IP Base'. You need 'Advanced IP Services' or 'IP Services' for PIM SM.

As for distributed option, the keyword is inserted so it can run in hardware vs software.



Shaun Bender Thu, 03/31/2011 - 19:33


Using AirPlay on Apple iOS and Apple TV devices.

I've setup:

ip multicast-routing distributed

on a 3560 running IP Services and on the two vlans:

ip pim sparse-dense-mode

I'm able to see the Apple TV devices while on the same subnet, but once I switch to the other subnet, the devices are no longer visible.

Any suggestions?



This Discussion