Password recovery

Unanswered Question
Oct 16th, 2009

I am using 4507E catalyst as my HUB location which is connected with a Cisco 6509 Core switch and controlled by AAA server. I want to recover my HUB locations password. how can I do this ?I have tried to change it thru Confreg 0x2142 but again on reset, it asks the username instead of Switch> Please help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rite2anil Thu, 10/22/2009 - 00:28

Hi Glen,

I already tried this method but on resetting the hub switch, it again asks the username for authentication instead of Switch> prompt. I also tried to unplug the Core Switches Uplink cable to discunnect the AAA Server but the result is same.If you have any idea, please help me out.

glen.grant Thu, 10/22/2009 - 00:44

Do you get to the rommon prompt and then enter confreg 0x2142 ? If the register has been set I don't know how it could give you anything other than a switch with a blank config as it bypasses your startup config in this mode .You then copy your startup into running config and you modify whatever passwords you are using whether its a vty password or a username password and or enable secret password .Change the config register back to 0x2102 and then write mem the box and reload. Have never seen the recovery procedures fail. Can you post your exact procedures you are following otherwise I would look over that doc and again follow it step by step .

glen.grant Fri, 10/23/2009 - 03:58

At the rommon prompt try just using "confreg 0x2142 , then reset the box and see what happens. Looking at the post it says its at

0x2141 so this may be the problem.

******** The system will autoboot now ********

config-register = 0x2141

Autobooting using the first file from bootflash.....


This Discussion