Desktop Administrator Locked by another user

Unanswered Question
Oct 16th, 2009
User Badges:

Lately I have been having a problem making changes to workflow on my primary UCCX 7.0(1)SR3 server. I open desktop administrator and click on "Side A", then login to the desktop administrator site, but each time I get a popup saying that CDA is locked by another user. Am I doing something wrong?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.

On the CAD server (which in the UCCX case is the CRS box; in UCCE it is the PG), navigate to Program Files\Cisco\Desktop\bin and run ShowLicenseUsage.exe.


The IP address of the machine where CAD Admin is running will be displayed. Find that box and exit the program. Beat up the person who forgot to exit it! ;-)


Regards,

Geoff

Ryan LaFountain Mon, 10/19/2009 - 04:48
User Badges:
  • Cisco Employee,

Hi,


There is a bug opened for this but we are still trying to get a clean set of logs to provide to the development team for root cause.


If the problem is still happening, can you please open a TAC case and complete the following:


1. Se the WebAdmin debug level to DEBUG and set the files to 10


2. Set the LRMServer debug level to TRACE and set the files to 10


Try to login to the WebAdmin and get the message that another user is logged in. Wait 15 minutes. Try to navigate to another page like the Enterprise Data Fields page and see if the 'Save' button is activated or if you still get that message.


Collect the following:


1. WebAdmin*.dbg from C:\Program Files\Cisco\Desktop\log


2. LRMServer*.dbg from the same location


3. WebAdmin*.dbg from C:\Program Files\wfavvid\tomcat_appadmin\logs


Turn the Threshold=OFF for the LRMServer after the test.

Ryan LaFountain Mon, 10/19/2009 - 06:33
User Badges:
  • Cisco Employee,

The original poster said that he opened CDA and selected Side A. Selecting Side A will open Web CDA.

bsugamele1 Mon, 10/19/2009 - 06:48
User Badges:

Yes, I have been trying to open CDA by clicking on Side A. I am the only admin and for some reason when I log out of the CDA, it keeps the session open as when I try to log into it again later in the day it is giving me the message that another user has the system locked. I will open a TAC case and turn on the debugs. Thanks.

atalante Mon, 10/19/2009 - 06:35
User Badges:

Hi,


Did the SR4 solve this issue ?


thanks for your reply


Regards,

Farid

atalante Tue, 10/20/2009 - 01:36
User Badges:

Hi,


I opened an SR, the TAC advise me to reboot the node manager or the servers.

Issue not solved by the SR4


regards

Farid

Ryan LaFountain Tue, 10/20/2009 - 04:05
User Badges:
  • Cisco Employee,

Hi Farid,


This should be solved soon as we have dedicated a lot of resources to finding the root cause of this issue as it has popped up in many cases.


You can put the bug I mentioned in a previous post into Bug Toolkit on cisco.com and be alerted when it is fixed so that you can upgrade to that version and avoid this issue.

bsugamele1 Wed, 10/21/2009 - 10:11
User Badges:

Thanks for the replies. I'll make sure to log out each time. It's a good habit to get into.

tjugoretz Wed, 05/05/2010 - 12:41
User Badges:

The current workaround for this bug per Cisco TAC is to restart the Node Manager, however, simply restarting the 'Cisco Desktop Licensing and Resource Manager Service' will also accomplish this without any interruption of service.


Tom

vanessawhite Wed, 08/17/2011 - 15:11
User Badges:

Hi all,


I am having the same issue on a live system and am wanting to complete the wokaround mentioned above.

I have UCX 7.0 (1) and am wanting to DEFINATIVELY know if I restart the isco Desktop Licensing and Resource Manager Service' it will not have impact on service including Agents?


I have heard that this service effects Agents and CAD?


Can someone from CISCO please advise if I can safely stop and start this service in a live environment?


Your help is appreciated.


Thanks


Vanessa 

Brett Hanson Sun, 04/21/2013 - 22:56
User Badges:

We run version 8.0.2 so may be different.


I tried restarting the "Desktop Licensing and Resource Manager Service" (did it on both Publisher and Subscriber) - several times - but it made no difference and didn't resolve my issue.

It also did NOT impact on service.


In the end I solved it as follows:

http://snafder.blogspot.com.au/2013/04/cisco-desktop-administrator-is-locked.html


(Used the "Force-Release CDA Lock" function in CDA)

Actions

This Discussion