Performance testing results for 802.11g

Unanswered Question
Oct 19th, 2009
User Badges:

I have been performing some bandwidth testing using iperf and received some unusual results. The issue I see is an 1231G performing better as an autonomous AP versus an 1231G converted to light-weight. The light-weight 1231G performs similar to an 1142N regardless of whether it is autonomous of light-weight.


* 802.11b rates disabled

* Identical configs between 1231G and 1142N

* WPA2-PSK in use

* All the major settings are identical between the autonomous AP or WLC

* WLC is a 5508 running 6.0.182


I do not see this as an issue related to any interference etc as the results have been consistent over my testing over different channels.


My only thought is if WMM is causing a reduction in the bandwidth. I have tried adjusting many options in the GUI of the WLC but have seen no improvement.


Results below show around 3 Mbps less over the 1231G autonomous versus the rest. Looking at the beacons in AirMagnet of the autonomous versus light-weight, I can see very few differences apart from a few QoS fields.


1231G Autonomous:

* Ch 1: 17.6 Mbps (avg over 30 sec)

* Ch 6: 16.7 Mbps (avg over 30 sec)

* Ch 11: 15.8 Mbps (avg over 30 sec)

* Ch 3: 18.3 Mbps (avg over 30 sec)

* Ch 9: 19 Mbps (avg over 30 sec)


1231G Light-weight:

* Ch 1: 14.5 Mbps (avg over 30 sec)

* Ch 6: 13.7 Mbps (avg over 30 sec)

* Ch 11: 14.6 Mbps (avg over 30 sec)

* Ch 3: 15.0 Mbps (avg over 30 sec)

* Ch 9: 14.5 Mbps (avg over 30 sec)


1142N Autonomous:

* Ch 1: 12.9 Mbps (avg over 30 sec)

* Ch 6: 13.4 Mbps (avg over 30 sec)

* Ch 11: 14.2 Mbps (avg over 30 sec)

* Ch 3: 14.6 Mbps (avg over 30 sec)

* Ch 9: 14.8 Mbps (avg over 30 sec)


1142N Light-weight:

* Ch 1: 12.9 Mbps (avg over 30 sec)

* Ch 6: 13.1 Mbps (avg over 30 sec)

* Ch 11: 14.2 Mbps (avg over 30 sec)

* Ch 3: 14.4 Mbps (avg over 30 sec)

* Ch 9: 14.0 Mbps (avg over 30 sec)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jbarger Mon, 10/19/2009 - 06:32
User Badges:

I just tested throughput using a 700MB file as the only user connected to an 1131 using G protocol.

With excellent signal strength. Autonomous AP settings...

B is enabled.

QoS for voice.

version 124-10b.JDA

WPA2-AES

WLSE for management.


I am not impressed with the throughput, I have not tried to make any changes yet.

Here is a graph of the throughput.


Roughly 11mbps...

I tried searching the forums for recommendations and started my own post but have 0 responses.


I need to do more testing but it seems odd that you are getting about 1/4 of the available bandwidth and I am getting 1/5. I would think that somewhere around 25 Mbps would be more appropriate but I have never tested throughput before so I am going to have to get some more data.



Attachment: 
Leo Laohoo Mon, 10/19/2009 - 13:30
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

scott.stapleton Mon, 10/19/2009 - 16:59
User Badges:

jbarger: b-rates enabled are going to be the major reason for you achieving 11 Mbps. You also really need to use iperf, ixchariot or some other bandwidth testing software to get accurate numbers.


leolaohoo: I was just reading that - whilst interesting, it provides no clues as to what I am seeing.



jbarger Tue, 10/20/2009 - 06:08
User Badges:

Ok thanks for the information and sorry for the thread hijack :)


Now to get some statistics on how many actual "B" connections are used.

Robert.N.Barrett_2 Tue, 10/20/2009 - 10:14
User Badges:
  • Bronze, 100 points or more

For your 1140, be sure you are enabling ClientLink. For an autonomous AP:

To enable ClientLink, enter this CLI command in interface configuration mode on 802.11n radio interfaces:


beamform ofdm


I think it's a checkbox to enable it on a 6.0.182 controller (just can't remember where). You *WILL* see a performance improvement on the 1140 when you do this.


As others mentioned, your best throughput will be when you disable 802.11b support, and you ensure that there are no other 802.11b clients or APs within "earshot" of your test APs. If your AP hears 802.11b traffic, it will enable protection mode and slow everything down.

Robert.N.Barrett_2 Tue, 10/20/2009 - 10:23
User Badges:
  • Bronze, 100 points or more

I mentioned this below, but meant to put it here - be sure to enable ClientLink on the 1140 (autonomous and lightweight). You should see higher numbers (closer to 20Mbps with an 802.11g client if I remember correctly).


Since you have an AirMagnet, check the beacons and make sure you don't see protect mode enabled. If so, that's your problem, and it's due to 802.11b traffic on the same channel being "heard" by your AP.

scott.stapleton Tue, 10/20/2009 - 17:42
User Badges:

Clientlink was enabled on both the autonomous 1140 and the WLC for the 1140. I can't see how it will improve performance in this case however. The client is within a few metre's of the AP and the signal and snr are both plenty for a 54 Mbps rate. If the client was some distance from the AP, sure.


The b rates are disabled and an AirMagnet packet capture does not show RTS/CTS or CTS-to-Self protection being used.


I did notice in some cases beacons showing "Non-ERP station present: No" / "Use protection: Yes"). Why the AP would be telling clients to use protection if no b-clients were present, I do not know.


Regardless these results were consistent and if the autonomous 1230 was "hearing" b-clients I would expect the 1140 to be doing so also.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode