Manual QoS on Cisco Switch

Unanswered Question
Oct 19th, 2009

Hi All,

This is a topic which I am having alot of trouble with. Typically to implement qos on a switch I just use the Auto QoS but in this case it does not apply.

Lets say we have two switches connected over a WAN 100Mpbs Layer 2 link. I want to provide QoS on this link which connects the two sites. There is no voice or video, the only thing I want to do is guarantee bandwidth to a a few specific VLANS.

The switches in question are the Cisco Catalyst Blade Switch 3120

The following is what I have configured but I am unsure if this will work or make things worst.

I start by mapping the the COS values in to some queues

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 1 0

mls qos srr-queue output cos-map queue 2 threshold 1 5

mls qos srr-queue output cos-map queue 3 threshold 1 1

mls qos srr-queue output cos-map queue 4 threshold 1 2

*Here I want cos value 0 in Queue 1, 5 in Queue 2 and so on

Then I applied the mls qos cos # to the interfaces where i wont to tag the cos traffic

ex) Database interface is gi 1/0/5

interface GigabitEthernet1/0/26

mls qos cos 5

Next I apply my outbound queue settings. The link that connects the two sites is gi1/0/26

interface GigabitEthernet1/0/26

description LINK TO OTHER SITE

switchport mode trunk

srr-queue bandwidth share 35 45 15 5

* Here i assume it will give 35% of bandwidth to queue 1, 45% to queue 2, and so on.

Can anyone see anything major I may have missed? I know I have not set threshold values but I assume the defaults will do.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Edison Ortiz Mon, 10/19/2009 - 14:27

This should work - make sure to enable QoS globally in the switch as well with the 'mls qos' command.




This Discussion