871W - Wireless Devices Cannot Communicate with Each Other

Unanswered Question
Oct 19th, 2009

I am supporting a home setup of an 871W router. The user is reporting that he is able to access the Internet using the wireless from his PC, he can ping his wireless printer from the router, but the PC and printer cannot connect to each other.

Here is the config from the 871W... am i missing something?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
chrislisser Mon, 10/19/2009 - 09:13

!version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 debugging

logging console critical

!

no aaa new-model

!

resource policy

!

clock timezone PCTime 0

no ip source-route

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.0.0.1

!

ip dhcp pool sdm-pool1

import all

network 10.0.0.0 255.255.255.0

default-router 10.0.0.1

!

!

ip tcp synwait-time 10

no ip bootp server

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

crypto pki trustpoint TP-self-signed-1812774468

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1812774468

revocation-check none

rsakeypair TP-self-signed-1812774468

!

!

crypto pki certificate chain TP-self-signed-1812774468

certificate self-signed 01

30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

F60984C4 E46F56D7 C5313D

quit

!

!

!

bridge irb

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

description $ES_WAN$$FW_OUTSIDE$

ip address dhcp client-id FastEthernet4

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

!

encryption key 1 size 128bit 7 xxx transmit-key

encryption mode wep mandatory

!

ssid xxx

authentication open

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$

no ip address

ip tcp adjust-mss 1452

bridge-group 1

!

interface BVI1

description $ES_LAN$

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

!

logging trap debugging

access-list 1 remark INSIDE_IF=BVI1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.0.0.0 0.0.0.255

no cdp run

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

no modem enable

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

Lucien Avramov Mon, 10/19/2009 - 09:24

This sounds more related to perhaps a driver issue for the printer.

I understand that both printer and PC are on the same subnet by reading this show run, can you confirm that is the case?

The average network printer is responding to a brodcast request with its hostname and ip, that is how the PC detects it. Hence it's important by default to have both on the same subnet, else it becomes more tricky to configure.

Finally, what happens when the PC is wired connected? I presume, the same issue will happen.

chrislisser Mon, 10/19/2009 - 09:33

They are on the same subnet. I'm not sure about the rest. I will check with the user and have them test with the wired port tonight. I also asked that he update his PC wireless drivers. He said it did work wirelessly with his previous WLAN setup (without the 871W)

He is also reporting that he cannot ping the PC from the router, but he says there is no firewall running on the PC.

Lucien Avramov Mon, 10/19/2009 - 09:53

If he can ping the router from the PC but not the PC from the router, then it's obviously a firewall issue on the pc.

Actions

This Discussion