Bridge Mode over T1 - Even possible?

Answered Question
Oct 19th, 2009
User Badges:

I have two 2600 routers, each have a fast ethernet port and a wic1-dsu-t1. I have connected the T1 cards together with an Rj48c cable. When I configure those interfaces accordingly they are up/up and if I assign addresses they can ping back and forth. What I'm trying to do now is bridge the fast-ethernet ports to the wan connection on each router. When I do so all the ports appear up/up, but nothing is talking across. Below are the configs of router1 and router2. Router1 will be connected to a switch on my LAN. Router2 will have a computer connected via crossover cable. I'm trying to see if bridging the two routers together will allow the host connected to router2 to see the LAN conected to Router1.

My boss is the one that wants me to see if this is even possible (I have no idea why.) Can anyone tell me what I am missing?


ROUTER1:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

bridge irb

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

!

interface Serial0/2

no ip address

service-module t1 clock source internal

bridge-group 1

!


interface BVI1

!

ip http server

ip classless

!

!

bridge 1 protocol ieee

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end


ROUTER2:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

ip cef

!

!

!

bridge irb

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

!

interface Serial0/1

no ip address

bridge-group 1

!

interface BVI1

!

ip http server

ip classless

!

!

!

!

bridge 1 protocol ieee

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end


Correct Answer by Richard Burts about 7 years 8 months ago

Patrick


It is certainly possible to bridge Ethernet frames from an Ethernet interface through a serial interface, over a serial link, to a serial interface on another router, and then to the Ethernet interface of the other router. A device in the LAN of one router should be able to communicate with a device in the LAN of the other router - assuming that both devices are properly configured (as members of a common subnet).


Given what you show in the original post I would suggest that there is a more simple config that is possible (and probably desirable):

- remove the command for bridge irb

- remove the interface BVI1

- insert the command no ip routing


Let me also make the point that while it is certainly POSSIBLE to configure bridging to link 2 LANs over a serial link, it is generally not advised to do so.


HTH


Rick

Correct Answer by Peter Paluch about 7 years 8 months ago

Patrick, Giuseppe,


I have made a simple topology virtually identical to what the Patrick has set up, and I did not have any problems running a bridge over a serial line with HDLC or PPP. The configuration of a single bridging router was:


bridge irb


interface Fa0/0

bridge-group 1

no shutdown


interface Serial1/1

bridge-group 1

no shutdown


This worked just fine:


R2#show bridge


Total of 300 station blocks, 298 free

Codes: P - permanent, S - self


Bridge Group 1:


Address Action Interface Age RX count TX count

c003.4948.0000 forward Serial1/1 40 57 84

c000.4948.0000 forward FastEthernet0/0 40 89 54


Best regards,

Peter


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Correct Answer
Giuseppe Larosa Mon, 10/19/2009 - 10:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Correct Answer
Peter Paluch Mon, 10/19/2009 - 12:45
User Badges:
  • Cisco Employee,

Patrick, Giuseppe,


I have made a simple topology virtually identical to what the Patrick has set up, and I did not have any problems running a bridge over a serial line with HDLC or PPP. The configuration of a single bridging router was:


bridge irb


interface Fa0/0

bridge-group 1

no shutdown


interface Serial1/1

bridge-group 1

no shutdown


This worked just fine:


R2#show bridge


Total of 300 station blocks, 298 free

Codes: P - permanent, S - self


Bridge Group 1:


Address Action Interface Age RX count TX count

c003.4948.0000 forward Serial1/1 40 57 84

c000.4948.0000 forward FastEthernet0/0 40 89 54


Best regards,

Peter


Correct Answer
Richard Burts Tue, 10/20/2009 - 10:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Patrick


It is certainly possible to bridge Ethernet frames from an Ethernet interface through a serial interface, over a serial link, to a serial interface on another router, and then to the Ethernet interface of the other router. A device in the LAN of one router should be able to communicate with a device in the LAN of the other router - assuming that both devices are properly configured (as members of a common subnet).


Given what you show in the original post I would suggest that there is a more simple config that is possible (and probably desirable):

- remove the command for bridge irb

- remove the interface BVI1

- insert the command no ip routing


Let me also make the point that while it is certainly POSSIBLE to configure bridging to link 2 LANs over a serial link, it is generally not advised to do so.


HTH


Rick

Peter Paluch Tue, 10/20/2009 - 10:45
User Badges:
  • Cisco Employee,

Hi Rick,


I agree that the BVI1 interface is not needed in this example. However, my experimental network did not work without the "bridge irb" command. I haven't tried deactivating the IP routing, though. I'll give it a try.


Best regards,

Peter


Peter Paluch Tue, 10/20/2009 - 11:03
User Badges:
  • Cisco Employee,

Hello Rick,


Thanks for your hints! So I've come to these conclusions:


1.) Either the "ip routing" is left active, and then you need to configure the "bridge irb", otherwise the bridging is not operational


2.) Or the "ip routing" is deactivated and the bridge will work without any further configuration


Thanks!


Best regards,

Peter


epatrickwhite Mon, 11/23/2009 - 16:34
User Badges:

Thank you all for the info.  I was able to take this information to answer my question.

Actions

This Discussion