Problem with caller ID

Answered Question
Oct 19th, 2009
User Badges:
  • Bronze, 100 points or more

Hello,


We jsut recently switched from Comcast VoIP with an analog handoff to Verizon POTS lines. We didn't have to change a thing in our config. But now, all incomming calls have a caller ID of 9911? What could this be?


I confirmed that we have caller ID on our lines.


Thanks.

Brian

www.jaydien.com

Correct Answer by Marcos Hernandez about 7 years 2 weeks ago

Brian,


Try this:


UC500#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
UC500(config)#voice-port 0/1/0
UC500(config-voiceport)#caller-id alerting ring 2


Let me know,


Marcos

Correct Answer by Saurabh Verma about 7 years 7 months ago

Hi Brian,


Looks like all the incoming calls are matching the 1st POTS dial-peer that's configured for 911 calls. The only way to do this through CCA would be to start from scratch. I would recommend that you use CLI to create dial-peers for matching incoming calls (without any destination-pattern). For example, create the following dial-peers for each of your active FXO port:


dial-peer voice 5100 pots

  incoming called-number .%

  port 0/1/0


dial-peer voice 5101 pots

  incoming called-number .%

  port 0/1/1


dial-peer voice 5102 pots

  incoming called-number .%

  port 0/1/2


dial-peer voice 5103 pots

  incoming called-number .%

  port 0/1/3


HTH,

Saurabh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Saurabh Verma Tue, 10/20/2009 - 06:01
User Badges:
  • Silver, 250 points or more

Hi Brian,


Looks like all the incoming calls are matching the 1st POTS dial-peer that's configured for 911 calls. The only way to do this through CCA would be to start from scratch. I would recommend that you use CLI to create dial-peers for matching incoming calls (without any destination-pattern). For example, create the following dial-peers for each of your active FXO port:


dial-peer voice 5100 pots

  incoming called-number .%

  port 0/1/0


dial-peer voice 5101 pots

  incoming called-number .%

  port 0/1/1


dial-peer voice 5102 pots

  incoming called-number .%

  port 0/1/2


dial-peer voice 5103 pots

  incoming called-number .%

  port 0/1/3


HTH,

Saurabh

jaydien1358 Thu, 05/06/2010 - 10:05
User Badges:
  • Bronze, 100 points or more

Hello,


We recently switch carriers again, (from Verizon Back to Comcast), and now caller ID is showing as unknown on all displays and voicemail. We did not change the config at all when making the carrier change.


We have also confirmed that the feature is enabled wityh the carrier. Please advise. Thanks.


-Brian

www.jaydien.com

Correct Answer
Marcos Hernandez Thu, 05/06/2010 - 14:36
User Badges:
  • Blue, 1500 points or more

Brian,


Try this:


UC500#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
UC500(config)#voice-port 0/1/0
UC500(config-voiceport)#caller-id alerting ring 2


Let me know,


Marcos

jaydien1358 Fri, 05/07/2010 - 02:26
User Badges:
  • Bronze, 100 points or more

That seemed to work Marcos, thanks.


Wasn't the option for setting number of rings configurable under earlier versions of CCA? Or am I confusing that with something else? Kind of remember an option for choosing number of rings before the AA answers incoming calls.


-Brian

Marcos Hernandez Fri, 05/07/2010 - 06:11
User Badges:
  • Blue, 1500 points or more

No, currently this is only configurable via CCA. Glad that it worked.


Marcos

Actions

This Discussion