WAN router with QOS for specific IP's

Unanswered Question
Oct 19th, 2009
User Badges:

I have a 3745 router with one Fa port. I configured two ip ranges on that port and I want to create QOS on the WAN link to guar. 10 megs of traffic. How can i set that up for one ip range? does anyone have any sample configs i can see?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Collin Clark Mon, 10/19/2009 - 12:28
User Badges:
  • Purple, 4500 points or more

Here's a working example. You will want to double check my bandwidth numbers.


access-list 185 permit ip 10.28.9.0 0.0.0.255 any


class-map match-all HR

match access-group 185

!

!

policy-map RestrictHR

class HR

police 10000000 50000 50000 conform-action transmit exceed-action drop violate-action drop

interface fa1

service-policy output RestrictHR

D0nprintup_2 Mon, 10/19/2009 - 12:36
User Badges:

now does that restrict all other IP's? I want to Guarantee lets say 7 megs to 32 ips. Now it can use more if needed. I want to give 13 megs to the rest but restrict that so it cannot go over 13 megs.


Edison Ortiz Mon, 10/19/2009 - 14:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The configuration provided by Collin will restrict the flow from those IPs to 10Mbps.


If you want to guarantee bandwidth on egress, you will need CBWFQ and the syntax would be as followed:


access-list 101 permit ip [32 IPs] any


class-map QoS_WAN

match access-group 101


policy-map QoS_WAN

class QoS_WAN

bandwidth 7000

class class-default

bandwidth 13000

random-detect


interface fx/x

description WAN Facing Interface

service-policy output QoS_WAN


Why would you want to limit the remaining traffic to 13Mbps? If you aren't using the 7Mbps, ideally - you want to have the remaining traffic to use that bandwidth.


Regards,


Edison



Actions

This Discussion