cant hear the other party ringing

Unanswered Question
Oct 19th, 2009

cucm 7 issue

when calling outside from any ip phone

-you cannot hear from the ip phone that the called party was ringing. you will just come to know that you are connected when the called party speaks up.

problem is, this is happening intermittently..

thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
virverma Tue, 10/20/2009 - 00:39

VOIP to PSTN and ip phone cannot hear ringback,

Complete one of these solutions:

1.

Ringback tones must come from the PSTN for trunk circuits in this situation. There are two dial-peer subcommands which can help. On the Cisco IOS router/gateway under the outgoing voice dial-peer # pots, configure these commands: .

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

The progress_ind alert enable 8 command presents the Q.931 alert message to the software on the router/gateway as if the alert message had a PI of 8 and cut through the audio path. Refer to Configuring Progress Indicator in H.323 POTS Dial Peers for more information.

Note: The progress_ind alert and progress_ind setup commands are hidden in some versions of Cisco IOS Software and can potentially not be visible within the help parser. However, if the progress_ind progress command is available in the help parser, these commands are also available and can be entered into the dial peer in their entirety. These commands subsequently appear in the running configuration.

2.

If the previous command does not solve the problem, in Cisco IOS Software Releases from 12.2(1) to 12.2(2)T and later, configure the progress_ind setup enable 3 command under the voice dial-peer # pot configuration.

This command causes the gateway to send a PI with a value of 3 in the ISDN Setup message. This indicates to the PSTN/PBX that the originating device is a non-ISDN device and in-band information needs to be presented. It is recommended that this command be used in conjunction with the progress_ind alert enable 8 command.

3.

If the PSTN device is not able to generate ringback in-band (for example an ISDN phone directly connected to a BRI port on the gateway), the gateway can be configured to generate ringback on the IP call leg by configuring the tone ringback alert-no-pi command on the dial-peer voice # pots.

When the ISDN alert is received with no PI present, the gateway generates the ringback in and includes a PI=0x8 in the H.225 alert message.

cfajardo1_2 Tue, 10/20/2009 - 01:54

in my case the problem is intermitent...does this solution also applies

virverma Tue, 10/20/2009 - 07:55

Yes, it should help

and it does not cause any major issue

cfajardo1_2 Tue, 10/20/2009 - 08:59

Should the commands on item 1 be invoked on the below dial peers?

What about if it doesnt work? item no 2 suggest to invoke another command. will it be on the same dial peers? do i have to remove the commands i invoked on item no.1 befor inviking comand on item no.2?

dial-peer voice 1 pots

destination-pattern .T

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 2 pots

destination-pattern .T

direct-inward-dial

port 0/0/1:15

thanks

Brian Carlson Tue, 10/20/2009 - 16:08

Try this, I bet it will resolve your issue.

1. Configure an IOS MTP (Media Termination Point) on your voice gateway

sccp ccm group 1

bind interface Loopback0

associate ccm 1 priority 1

associate profile 1 register GW_MTP

dspfarm profile 1 mtp

description Media Termination Point

codec g711ulaw

maximum sessions hardware 8

associate application SCCP

2. On your gateway, check the box that says "Media Termination Point Required"

3. Make sure your Gateway has access to the MTP via it's MRGL

That should clear it up.

Brian Carlson Tue, 10/20/2009 - 16:10

I forgot to mention, you also need to configure the MTP within CUCM as well. If configured correctly you'll see it register.

virverma Tue, 10/20/2009 - 16:31

MTP could not be the issue here

MTP service can provide supplementary services such as hold, transfer, and conferencing when the service is using gateways and clients that do not support the H.323v2 feature of EmptyCapabilitiesSet.

When MTP is running in software on Cisco Unified Communications Manager, the resource supports 48 MTP sessions. When MTP is running on a separate Cisco Unified Communications Manager appliance (server), the resource supports up to 128 MTP sessions.

so hardware is required only when more resources are required and here the issue is we do not hear the ring back

Brian Carlson Tue, 10/20/2009 - 16:35

You may be correct, but I had a very similar issue that was only resolved after configuring an IOS MTP on the gateway and checking MTP required on the gateway within CUCM. We also had to configure in/outbound Faststart.

On your gateway within CUCM, you might check "Inbound Faststart Enabled" and "Outbound Faststart Enabled" which could also fix the ring back issue.

If you check "Outbound Faststart Enabled" you need an MTP, FYI.

cfajardo1_2 Wed, 10/21/2009 - 10:58

Hi,

have tried your suggestion..looks okay..its under observation...

Actions

This Discussion