Failover using static routes

Unanswered Question
Oct 20th, 2009

Hi

I have Site A and Site B connected via LAN-X.I brought in secondary LAN-X for backup purposes and tried to implement it using static routes for the fact that ONLY static routes be used to achieve failover.I have tried to unplug the PRIMARY LINK cable from switch from site B and it did not failover.please see the config below and advise..I also checked the ip route table on all switches and I did not see the route usingbackup interface.I have also tried using INTERFACE command in static route to make sure routes are deleted once the link is down but this did not help either...

Note : SWITCH-1 and SWITCH-2 are UPLINKED at SITE A

SWITCH -1 :SITE A

interface FastEthernet3/1

description PRIMARY-LAN-X

no switchport

ip address 10.100.100.1 255.255.255.248

speed 100

duplex full

end

interface Vlan90

description GroundFloor

ip address 10.32.90.2 255.255.254.0

ip helper-address 144.1.4.40

standby 10 ip 10.32.90.1

standby 10 priority 105

standby 10 preempt

interface Vlan24

ip address 10.32.0.7 255.255.252.0

standby 24 ip 10.32.0.6

standby 24 priority 105

standby 24 preempt

ip route 10.32.50.0 255.255.255.0 10.100.100.2

ip route 10.32.50.0 255.255.255.0 10.32.90.3 2(Admin Distance)

ip route 10.32.52.0 255.255.255.0 10.100.100.2

ip route 10.32.52.0 255.255.255.0 10.32.90.3 2(Admin Distance)

SWITCH -2 :SITE A

interface FastEthernet3/1

description BACKUP-LAN-X

no switchport

ip address 10.200.200.1 255.255.255.248

ip policy route-map ToStoresVia3000

speed 100

duplex full

end

interface Vlan90

description GroundFloor

ip address 10.32.90.3 255.255.254.0

ip helper-address 144.1.4.40

standby 10 ip 10.32.90.1

standby 10 preempt

interface Vlan24

ip address 10.32.0.8 255.255.252.0

ip policy route-map ToStoresVia3000

standby 24 ip 10.32.0.6

standby 24 preempt

ip route 10.100.100.0 255.255.255.248 10.32.90.2

ip route 10.32.50.0 255.255.255.0 10.32.90.2

ip route 10.32.50.0 255.255.255.0 10.200.200.2 2(Admin Distance)

ip route 10.32.52.0 255.255.255.0 10.32.90.2

ip route 10.32.52.0 255.255.255.0 10.200.200.2 2(Admin Distance)

SWITCH -3 : SITE B

interface GigabitEthernet1/0/24

description PRIMARY-LanX

no switchport

ip address 10.100.100.2 255.255.255.248

speed 100

duplex full

interface GigabitEthernet2/0/1

description BACKUP-LAN-X

no switchport

ip address 10.200.200.2 255.255.255.248

speed 100

duplex full

Interface Vlan5

description Server VLAN

ip address 10.32.50.1 255.255.255.0

interface Vlan52

description LAN/WAN Admin VLAN

ip address 10.32.52.1 255.255.255.0

ip helper-address 10.32.50.10

ip route 0.0.0.0 0.0.0.0 10.100.100.1

ip route 0.0.0.0 0.0.0.0 10.200.200.1 2(Admin Distance)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 10/20/2009 - 09:07

Hello,

depending on how the sites are interconnected (=if there is anything in between a switch or firewall) you may need to add some intelligence and to use reliable static routing to check reachability of IP next-hop of primary route.

see

http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html

more specifically

http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html#wp1070516

real implementation of the probe depends on IOS version

if the cable is direct unplugging should make the interface on the other side to go down.

Then the ARP entry for IP next-hop should be removed and also the static route.

Hope to help

Giuseppe

CCDECCDE9 Tue, 10/20/2009 - 13:30

The connections are point to point and nothing in between.I am at IOS 12.2(18).I have done this before with routers and it worked and this time these are layer-3 switches.And how did we do this redundancy before this IP SLA came out and ALSO what is the advantage of using Admin Distance with static routes .Thanks

vmiller Tue, 10/20/2009 - 14:09

When you test, do you see the link go into a down status? Some metro type services will keep layer 1 &2 up even though layer 3 is down. One method I have used is to point to an interface instead of an address for next hop.

By adding an admin distance to the backup route, you make it less preferred than the primary. once the primary goes down, its AD goes to 255...the the one at 2 is more preferred.

CCDECCDE9 Tue, 10/20/2009 - 17:23

I did not check because I unplugged the cable and was checking routes all the time to see if the routing table changes with new next hop..

Actions

This Discussion