eBGP Cisco => Juniper (no Prefixes advertised)

Unanswered Question
Oct 20th, 2009
User Badges:

Hi !


I am trying to establish an additional eBGP session to a Juniper Router. A running bgp session (cisco-cisco) is already there. Just trying to establish an alternative route - receive full BGP table and announce 2 prefixes.


The eBGP Session to the Juniper is established - I am able to receive the routes - but I am not able to send our prefixes - for the other eBGP Session that is working fine.


sh ip bgp neighbors Provider B advertised-routes


Total number of prefixes 0


-------------------------


sh ip bgp neighbors Provider A advertised-routes


Total number of prefixes 2


---------------------------


neighbor ProvB remote-as X

neighbor ProvB description X

neighbor ProvB version 4

neighbor ProvB next-hop-self

neighbor ProvB prefix-list XYZ out



I would really appreciate any help...


thx

Hans

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 10/20/2009 - 10:08
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Hans,

I see you have applied a prefix-list outbound = outbound route filter


check if the prefixes that should be advertised are permitted by that prefix-list.


>> neighbor ProvB prefix-list XYZ out


Hope to help

Giuseppe


schimeha1977 Tue, 10/20/2009 - 10:12
User Badges:

Hi !


yes it is - if I remove the prefix-list, still 0



br

Hans

Giuseppe Larosa Tue, 10/20/2009 - 10:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Hans,

after removing the filter have you used a form of clear ip bgp (soft mode or hard mode)?


without this the new policy is not applied immediately.

Also check if the prefixes that should be advertised have the best path via the juniper router.

if so the device cannot advertise back its best choices to the same peer.


Hope to help

Giuseppe

Actions

This Discussion