outside source static NAT

Unanswered Question
Oct 20th, 2009
User Badges:

I'm having an issue with static NAT over an ISDN interface. Router won't dial.


the outside source addresses are natted to IP addresses from the local ethernet0 subnet


config is:


username xxxxxxx password 7 082814680E10304E46


isdn switch-type basic-net3


interface FastEthernet0

ip address 192.168.243.49 255.255.255.240

ip nat inside

no ip route-cache

speed auto


interface BRI0

no ip address

ip nat outside

encapsulation ppp

no ip route-cache

dialer pool-member 1

dialer pool-member 2

no snmp trap link-status

isdn switch-type basic-net3

no cdp enable

ppp authentication chap


interface Dialer1

description ****ISDN****

ip address 194.15.247.34 255.255.255.252

ip nat outside

encapsulation ppp

dialer pool 2

dialer remote-name xxxx

dialer idle-timeout 360

dialer string 00123123123123

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname xxxxx

ppp chap password 7 030D082D010614345


ip nat outside source static 172.27.34.53 192.168.243.53

ip nat outside source static 172.27.34.52 192.168.243.52


ip route 172.27.34.52 255.255.255.255 Dialer1

ip route 172.27.34.53 255.255.255.255 Dialer1


dialer-list 1 protocol ip permit


i'm sure its a problem with the NAT


SHOW IP NAT TRANS YIELDS:


Pro Inside global Inside local Outside local Outside global

--- --- --- 192.168.243.52 172.27.34.52

--- --- --- 192.168.243.53 172.27.34.53


which is correct.


the isdn does work as i can ping accross the dialer to the other end. The problem is when a user on the inside targets the NAT address, the router won't dial.


any ideas


regards


Andy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 10/21/2009 - 01:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Andy,

what if you add also the mirrored NAT static entries for inside to outside?


with your current configuration NAT works well if the session is started from outside to inside.



you may consider to add the option extendable


http://www.cisco.com/en/US/docs/ios/ipaddr/command/reference/iad_nat.html#wp1011984



Hope to help

Giuseppe


Actions

This Discussion