Displaying Photo's in CUCIMOC

Unanswered Question
Oct 20th, 2009

Hi,

I am looking to display photos in MOC as per the following doc

https://www.cisco.com/en/US/docs/voice_ip_comm/cucimoc/7_1/english/integrat/guide/appendixb.html#wp1015019

It is vague when it comes to creating the scheme attribute for the PhotoUri OID.

What should this value be?

I know there are tools like oidgen.exe that will generate a random number for this, but it seems like that is probably not best practice.

Does anyone have any recommendations?

Thanks

Frank

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tommer Catlin Tue, 10/20/2009 - 07:22

Basically, you do not need that tool. You need to have the photos of the person on a website already. Such as http://intranet/johnsmith.jpg

Once you have that working, go John Smith in AD, and place the URL in their profile on "web Page" CUCIMOC will pull from there then

fmarottactg Tue, 10/20/2009 - 10:21

I configured the following:

-Set the web page attribute for the users in AD to http:///employees/

-Set the LDAP_AttributeName_photoUri value to wWWHomePage

I am able to see the photo if I open the url in a web browser.

I do not see the photo in the conversation pane.

Am I missing something?

Does the photo need to be a certain size?

Thanks

Frank

Tommer Catlin Tue, 10/20/2009 - 10:27

you enabled it on the Group Policy?

Also, you may need to wait for everything to replicate to the machine you are testing. The photos are simply in active directory by LDAP lookups. So double check your LDAP settings. If you are using 3268 for the Global Catalog server, etc. 389 of course is default, but if the AD LDAP server you are using in CUPC is a GC, use 3268. It may fix your problem

fmarottactg Tue, 10/20/2009 - 10:34

Yes I enabled all settings via Group Policy. I have verified that my PC pulled the new policy by check the registry on that PC.

I am not following you with the global catalog ports suggestion. The AD server is my only DC in my domain (this is a lab) so I should not have any domain sync issues here.

Tommer Catlin Tue, 10/20/2009 - 10:37

If it's the first DC in your lab domain, its probably your Global Catalog server. In that case, change the LDAP port from 389 to 3268 in the LDAP lookup.

fmarottactg Tue, 10/20/2009 - 11:00

That did not help.

I a assuming you wanted me to set the LDAP_Server_1 value th "ldap://:3268"

This is a Windows 2008 DC. Not sure if that makes a difference.

shaikh ibrahim Sun, 12/11/2011 - 07:04

hi there ,

           i am facing the same issue . can any one help me ?????.........

Actions

This Discussion