1140's not broadcasting N speeds

Unanswered Question
Oct 20th, 2009

Just purchased a few 1140 cisco AP's with a 2106 Lan Controller. Configured everything as stated by the manual and I can not connect at N speeds. We have two buildings, in the other building on the same network we have a 2006 Lan controller that has 4 1130's configured.

So my issue at hand right now is I am not able to connect at the N speed. Could this be an issue from mixed mode? I am a little confused on where to start.

Thank you,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Robert.N.Barrett_2 Tue, 10/20/2009 - 07:34

What is your WLAN config? You must be using WPA2/AES (or no encryption) to get the N speeds. Post a sanitized version of your controller config if you're not sure.

jlight80911 Tue, 10/20/2009 - 07:51

Just enabled WP2 Encryption, and setup my laptop and it only put out 54 MBPS at Excellent strength. I have a Vaio u7600. So I do not think encryption is my issue here.

Robert.N.Barrett_2 Tue, 10/20/2009 - 07:55

WPA2 with AES, right? Not TKIP, and not WPA and WPA2 at the same time.

What wireless NIC does your u7600 use? The Intel 4965? Are the drivers up to date? Is 802.11n enabled on the controller, and on the wireless NIC?

What code level are you running on the WLC?

jlight80911 Tue, 10/20/2009 - 07:58

Correct, WPA2 with AES.

The Viao is running the Intel 4965AGN with updated drivers

The Controller is running 5.2.178.0 Code.

Robert.N.Barrett_2 Tue, 10/20/2009 - 08:03

Can you sanitize the controller config and upload it here? Sounds like you've got everything set correctly. The only thing that might be causing a problem is that some 4965 cards had the 802.11n disabled. I think this was only on certain ThinkPads, though. You'd know, because the card would be listed in Device Manager as a 4965AG.

Also - are you using Intel PROSet, or Windows Wireless Zero Config? What OS are you running? If you are on XP SP2, did you apply the wireless update?

jlight80911 Tue, 10/20/2009 - 08:08

I am running Windows Vista Business, running the windows Zero Config, I also have another Vaio running windows XP with the wireless update on it. I will try to get a config file and upload within the hour.

Robert.N.Barrett_2 Tue, 10/20/2009 - 08:18

I don't suppose you have a wireless sniffer hanging around that can show you what speeds are being advertised in the beacons, do you?

jlight80911 Tue, 10/20/2009 - 09:22

Unfortantly i do not, i tried netstubmler just now but it did not work. One thing i noticed under the WLC on the web GUI was that the Radio policy, it only gives you the option to do a/g, b/g, or all. Mines set to b/g, to my surprise shouldn't b/g/n be in the spot? It's under the WLAN options

Robert.N.Barrett_2 Tue, 10/20/2009 - 09:44

Cisco doesn't support n-only configurations, so the radio policy is somewhat accurate. As you noticed, you can enable/disable 802.11n support on the 2.4GHz and 5GHz radios individually via the Wireless page.

I would like to see an "n-only" option as well, but Cisco doesn't see the logic that it would be great to have 802.11b/g on the 2.4GHz radio for legacy support, and use pure (aka Greenfield) mode for the 5GHz radio. In the US, this would make a lot of sense because many people have not deployed 802.11a. Other vendors, (cough..Motorola..cough..Aruba..cough), support Greenfield mode. Of course, these folks also support 3 x 3 MIMO, which Cisco does not plan on supporting any time soon, either.

jlight80911 Tue, 10/20/2009 - 10:57

hmm ya iv pretty much just ripped apart my network now. 2006 is out of the picture, just the 2106 is connected, and being configured by WCS 5.2.148. I have two laptops thats are N capable, the vaio, and the Dell M6400 laptop. I will try to get the config file here soon and load it up. Can you explain why i have to use WAP2 with AES security? We just use simple mac filtering and do not broadcast our network. Thank you.

jakew Tue, 10/20/2009 - 11:04

11n HT rates require either open or AES encryption. WEP & TKIP aren't supported with 11n HT rates.

Check to be sure WMM is either allowed or required on your WLAN. WMM is also required for 11n as packet aggregation is determined by the AC.

Also... you've probably done this already, but I've made this mistake before... Be sure you've enabled 11n data rates.

jlight80911 Tue, 10/20/2009 - 11:12

So i run just mac filtering that is all. I should be fine correct? I am getting the config file now.

Robert.N.Barrett_2 Tue, 10/20/2009 - 11:05

The 802.11n standard requires WPA2/AES or no encryption. In Chapter 4 of the 5.2 guide, you'll see the following (forgot to ask if you have WMM enabled):

Note The 802.11n high-throughput rates are available only on 1140 and 1250 series access points for WLANs

using WMM with no Layer 2 encryption or with WPA2/AES encryption enabled.

jakew Tue, 10/20/2009 - 11:11

Note: Greenfield mode is not the same as 11n only. GF mode doesn't have any protection bits against legacy modulation schemes. GF mode also requires chipset support, which those "other" vendors don't actually have.

We say you need at least legacy data rate enabled for good reason: to protect your network against interference from legacy wi-fi. If you have only 11n clients and no interference, then you'll only use 11n anyway, so there is no actual gain with what the "other" guys do.

Secondly, be careful what you believe about the "other" guy's 3x3 mode. Their "3x3" only means the AP can transmit out of 3 antennae, which has negligible benefits. It does not give them a 3rd spatial stream. And we'll crush them on rate/range/coverage consistency/AP quality any day.

jlight80911 Tue, 10/20/2009 - 11:54

Alright everyone, so I enabled WMM on the WCS, and applied it to the controller. As soon as I did that, the Vaio could no longer renew its IP address. Any ideas what might cause that?

But I was able to get the N speed, just not pull a DHCP IP address.

jlight80911 Tue, 10/20/2009 - 12:14

Tried, multiple times on 4 different laptops, I noticed in the GUI it said AUT: no.

Any thoughts? I am going through the 5.3 guide right now to see if I am missing anything.

Robert.N.Barrett_2 Tue, 10/20/2009 - 12:34

Are you sure you only changed the WMM setting?

Closely compare your WLAN definition to the config on your client.

If you have SSID broadcast enabled, try blowing away the network definition on your client and go through the "View Available Wireless Networks" route to add it back.

Robert.N.Barrett_2 Tue, 10/20/2009 - 12:40

Thanks for the clarification. I figured that, by definition, "n-only" mode would disable all support (beacons, preambles, etc.) for HT_MF, thus enabling HT_GF.

My clients have a large amount of distance from other companies, and they are pretty strict on the rules and enforcement of what can operate in the RF air space. I can see where a lot of DoD sites would enjoy the same beenfits. For these clients, if they have no 802.11a clients/AP's, or other devices, operating in that frequency range, then why would they care about legacy support/protection? They have indicated to me that they want to put their non-802.11n machines on a "legacy" 2.4GHz network and save the 5GHz for "pure" (their words) 802.11n clients with 40MHz channels.

jlight80911 Tue, 10/20/2009 - 13:16

Thanks everyone for baring with me here. I found out the issue was my Mac address filtering. Looks like if im going to be running N speed, I need to figure out a new way of security for guest computers. It was easier to just add there mac address.

Thanks for the input everyone!! I got it to work!

dlawson001 Thu, 10/22/2009 - 11:45

MAC filtering is a joke. Its less secure than WEP. Ditch it since it wastes overhead and is incredibly easy to break. Not broadcasting your SSID is good for control of what users see but you aren't fooling a Wardriver for 2 seconds. They use applications that can read SSID's in the air even if they aren't being broadcasted.

The only true security you can offer your clients is WPA2 to encrypt the traffic.

Lucien Avramov Thu, 10/22/2009 - 11:59

I disagree. It is easy to break only if you know the mac address.

It is actually a very good security to have.

Robert.N.Barrett_2 Thu, 10/22/2009 - 13:40

But the MAC addresses are viewable in each packet transmitted over the air - unencrypted. MAC filters only stop the casual user. It will not stop a determined hacker, only delay them a few seconds.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode