Total Output drops on switchport

Unanswered Question
Oct 20th, 2009
User Badges:

I have a 3750 connected to a storage device and I am seeing alot of Total output drops on the input queue


Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 76207

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 31734000 bits/sec, 4366 packets/sec

5 minute output rate 37218000 bits/sec, 4632 packets/sec

1784158 packets input, 1564949850 bytes, 0 no buffer

Received 1 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

1940220 packets output, 1986930582 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output



I know you can increase the hold queue but that did not help either. I am using the lastest IOS c3750-ipservicesk9-mz.122-50.SE3. Would anyone have any suggestions ?


Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Yudong Wu Tue, 10/20/2009 - 08:43
User Badges:
  • Gold, 750 points or more

In general, output drop is caused by a busty traffic pattern. You can use the command "show platform port-asic stats drop gig x/y" to see which queue is dropping the packet. And then try to adjust your queue setting by related "mls qos queue-set output" commands.


keithannette Wed, 10/21/2009 - 03:06
User Badges:

Thanks for the reply. Here is the output


show platform port-asic stats drop gig 1/0/1


Interface Gi1/0/1 TxQueue Drop Statistics

Queue 0

Weight 0 Frames 0

Weight 1 Frames 0

Weight 2 Frames 0

Queue 1

Weight 0 Frames 0

Weight 1 Frames 0

Weight 2 Frames 0

Queue 2

Weight 0 Frames 0

Weight 1 Frames 0

Weight 2 Frames 0

Queue 3

Weight 0 Frames 0

Weight 1 Frames 0

Weight 2 Frames 175458


sh mls qos queue-set

Queueset: 1

Queue : 1 2 3 4

----------------------------------------------

buffers : 25 25 25 25

threshold1: 100 200 100 100

threshold2: 100 200 100 100

reserved : 50 50 50 50

maximum : 400 400 400 400

Queueset: 2

Queue : 1 2 3 4

----------------------------------------------

buffers : 25 25 25 25

threshold1: 100 200 100 100

threshold2: 100 200 100 100

reserved : 50 50 50 50

maximum : 400 400 400 400


If I do sh mls-qos


QoS is disabled

QoS ip packet dscp rewrite is enabled



What be the best way to change these settings ?


Thanks

iyde Wed, 10/21/2009 - 11:54
User Badges:
  • Silver, 250 points or more

Hi.

First thing is to enable QoS, as it is currently disabled:

"If I do sh mls-qos


QoS is disabled"


HTH

Actions

This Discussion