VLAN Down

Answered Question
Oct 21st, 2009
User Badges:
  • Super Silver, 17500 points or more
  • Cisco Designated VIP,

    2017 Firewalling, Network Management, VPN

I am having trouble bringing up a second VLAN on a Catalyst 3750 running 12.2(25)SEE.


The first VLAN (101) is working fine. The second (102) is Down/down. Here are the config sections that I have scripted:


bbswitch0-live#sh run int Vlan101

Building configuration...


Current configuration : 186 bytes

!

interface Vlan101

ip address 85.205.15.246 255.255.255.252

ip access-group fromvodafone in

ip access-group tovodafone out

no ip redirects

no ip unreachables

no ip proxy-arp

end


bbswitch0-live#sh run int gi0/49

Building configuration...


Current configuration : 240 bytes

!

interface GigabitEthernet0/49

description P2p OneNet - FRA/DUS/LE-069137

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101,102

switchport mode trunk

switchport nonegotiate

mls qos trust dscp

no cdp enable

end


bbswitch0-live#





bbswitch0-live#sh run int Vlan102

Building configuration...


Current configuration : 185 bytes

!

interface Vlan102

ip address 85.205.13.74 255.255.255.252

ip access-group fromvodafone in

ip access-group tovodafone out

no ip redirects

no ip unreachables

no ip proxy-arp

end


bbswitch0-live#sh int vlan101

Vlan101 is up, line protocol is up

Hardware is EtherSVI, address is 0013.c4d0.d041 (bia 0013.c4d0.d041)

Internet address is 85.205.15.246/30

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:03, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

24626854 packets input, 2522968725 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

23162770 packets output, 2004417061 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

bbswitch0-live#sh int vlan102

Vlan102 is down, line protocol is down

Hardware is EtherSVI, address is 0013.c4d0.d046 (bia 0013.c4d0.d046)

Internet address is 85.205.13.74/30

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

bbswitch0-live#



Any ideas? TIA.



Correct Answer by Jon Marshall about 7 years 7 months ago

Marvin


1. Yes vlan 102 is created. See my "sh int Vlan102" output in the original post.


thats the L3 vlan interface not the L2 vlan.


When you do a "sh vlan" do you see vlan 102. If not you need to create it at L2 ie.


3750(config) vlan 102 name


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Wed, 10/21/2009 - 05:57
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

2 things to check


1) have you created vlan 102 at L2 ie.


3750(config)# vlan 102 name


2) Is the trunk link up. I appreciate that vlan 101 is up/up but is there perhaps another active port on the switch in vlan 101 that is bringing that interface up.


Jon

Marvin Rhoads Wed, 10/21/2009 - 06:05
User Badges:
  • Super Silver, 17500 points or more
  • Cisco Designated VIP,

    2017 Firewalling, Network Management, VPN

Thank you for your suggestions jon.


1. Yes vlan 102 is created. See my "sh int Vlan102" output in the original post.


2. vlan 101 is only defined on a trunk port - no access ports. Here is a snippet of "sh VLAN":


bbswitch0-live#sh vlan


VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active

101 P2P Link VF One Net active



Neither VLAN 101 or 102 have any access ports - only trunking and only on port gi0/49 (config in the o.p.). They are being used for BGP peering with an external AS.

Correct Answer
Jon Marshall Wed, 10/21/2009 - 06:08
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Marvin


1. Yes vlan 102 is created. See my "sh int Vlan102" output in the original post.


thats the L3 vlan interface not the L2 vlan.


When you do a "sh vlan" do you see vlan 102. If not you need to create it at L2 ie.


3750(config) vlan 102 name


Jon

Marvin Rhoads Wed, 10/21/2009 - 06:17
User Badges:
  • Super Silver, 17500 points or more
  • Cisco Designated VIP,

    2017 Firewalling, Network Management, VPN



That was it. So simple.


I'm thinking that stores the VLAN info in vlan.dat which is why I was failing to see the problem by examining the config, correct?

Jon Marshall Wed, 10/21/2009 - 06:19
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Marvin


"


That was it. So simple."


No problem, happened to me a couple of times in the past as well :-)


If your switch is in VTP server or VTP client mode then yes you won't see the vlan info in the running config. VTP transparent will have it in the running config.


Jon

iyde Wed, 10/21/2009 - 10:27
User Badges:
  • Silver, 250 points or more

Hi.

Show vlan brief is a good command to remember if you are unsure whether you've created the L2 VLAN - has helped me a couple of times.

HTH

Actions

This Discussion