L2TPv3 help required

Unanswered Question
Oct 21st, 2009
User Badges:

Good day all


I'm having an issue implementing L2TPv3 between two sites. I am issuing the xconnect command to the subinterface which I want to connect, and I get this error:


"Incompatible with ip address command on Fa0/0.2"


Now I need the IP on the interface as hosts point to it for routing purposes. Is there a way to work around this problem?


Thanks



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 10/21/2009 - 06:47
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,

unfortunately you would need a second subinterface using same Vlan-id on a different Fastethernet port to provide both L2 and L3 services to the same vlan.


something like


int fas0/0.2

enc dot1q 2

ip address 10.2.2.1 255.255.255.0


int fas0/1.2

enc dot1q 2

no ip address

xconnect ...


with both interfaces connected to L2 trunk ports of an external LAN switch.


Hope to help

Giuseppe


osiristrading Wed, 10/21/2009 - 08:44
User Badges:

OK I've managed to get the commands entered, but I cannot ping (or even ARP) for hosts the other side of the link.


One the one side of the link I am running the xconnect on a subinterface, but on the other the xconnect is on the main interface (there are no subinterfaces). Could this have something to do with the problem?

Giuseppe Larosa Wed, 10/21/2009 - 08:46
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jason,


>> One the one side of the link I am running the xconnect on a subinterface, but on the other the xconnect is on the main interface (there are no subinterfaces). Could this have something to do with the problem?


I would say yes


try to have xconnect on subif also on the other site.


Hope to help

Giuseppe


Actions

This Discussion