Inventory Collection problem for RME 4.3.1 LMS 3.2

Unanswered Question
Oct 22nd, 2009

I recently upgraded from LMS 3.1 to LMS 3.2 and RME v 4.3.1. I have problems with the inventory collection. It will start scanning, but stops after approximately 10 devices. The rest of them will have a pending state. If I stop the collection job and start it again none (0) devices will be scanned. If I restart the ICServer it will result in the first option. That is, it will scan only 10 devices and then stop. I have extended the SNMP timeout to 30 secs and zero retries. Any suggestion would be appreciated

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 10/22/2009 - 07:45

There is most likely some device which is causing a loop or other error in ICServer. A full thread dump of ICServer at the time it locks up will be required to analyze it further. Open a TAC service request, and they can walk you through the procedure.

tfleitscher Fri, 10/23/2009 - 00:18

I have read through the dump and cant find anything in particular. Another discovery I've made is that the SNMP walk of an unsuccessful device takes 10 times longer than a successful device. An inventory job on a unsuccessful device only goes into pending and the job never starts.

Joe Clarke Fri, 10/23/2009 - 07:39

There appears to be some database issues here. It looks like you tried a huge delete operation, and this failed. If you have a known good backup of LMS, it would probably be a good idea to restore it, and see if you can regain inventory functionality.

tfleitscher Tue, 10/27/2009 - 01:23

That is odd. I tried a huge delete operation. Deleting all the devices in RME just to try to add all and give the collection a fresh start. The delete was successfull though. At least from the GUI point of view.

Joe Clarke Tue, 10/27/2009 - 05:37

It was not successful internally. Since things are in a bad state right now, try reinitializing the RME database with the command:

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=rmeng dmprefix=RME

Joe Clarke Fri, 10/30/2009 - 08:54

If the problem is the same in that inventory collection for a device locks up, and never completes, the full thread dump will be required to see what state the job and the ICServer process are in.

Actions

This Discussion