Mode change not accepted

Unanswered Question
Oct 22nd, 2009
User Badges:

Hi There I am trying to configure a tunnel to carry CLNS traffic using the following config


interface Tunnel0

description *** OSI Tunnel to Langley ***

no ip address

clns router isis

isis metric 21 level-1

tunnel source Loopback0

tunnel destination xxx.xxx.x.x

tunnel mode eon


and I am getting an error message of "Mode change not accepted"


The router is a 3825 running 12.4(15)T7


This config is working fine on 3600 routers running 12.2(29b)& 12.2(12)


Anyone else had this problem and is there a fix


Cheers


Mike

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 10/22/2009 - 10:04
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mike,

use a GRE tunnel instead


tunnel mode gre


on both ends


you may need to tune clns mtu and to disable hello padding to be able to setup IS-IS adjacency


I had used clns mtu 1460


Hope to help

Giuseppe


mscomms@hotmail.com Thu, 10/22/2009 - 23:41
User Badges:

I could give that a try and I will if I do net get a resolution but I have 15 - 20 of these tunnels and i would like to keep them standard.

Peter Paluch Fri, 10/23/2009 - 00:33
User Badges:
  • Cisco Employee,

Hi Mike,


When exactly do you get that error message? Can you perhaps post a complete transcript?


I was able to replicate your configuration without problems on 12.4(12) IOS for 2691 series routers.


Best regards,

Peter


mscomms@hotmail.com Fri, 10/23/2009 - 01:35
User Badges:

PENNER-DCNKR-02(config)#int tun 0

PENNER-DCNKR-02(config-if)#desc *** OSI tunnel to HX89 ***

PENNER-DCNKR-02(config-if)#clns router isis

PENNER-DCNKR-02(config-if)#isis metric 21 level-1

PENNER-DCNKR-02(config-if)#tun source lo0

PENNER-DCNKR-02(config-if)#tun dest xxx.xxx.x.x

PENNER-DCNKR-02(config-if)#tun mode eon

Mode change not accepted


PENNER-DCNKR-02(config-if)#^Z

PENNER-DCNKR-02#wr

Building configuration...

[OK]

PENNER-DCNKR-02#sh int tun 0

Tunnel0 is up, line protocol is down

Hardware is Tunnel

Description: *** OSI tunnel to HX89 ***

MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel source 213.186.5.172 (Loopback0), destination 213.186.5.3

Tunnel protocol/transport uninitialized

Tunnel TTL 255

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output 00:00:24, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

3 packets output, 1625 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

PENNER-DCNKR-02#

mscomms@hotmail.com Fri, 10/23/2009 - 01:36
User Badges:

Here is the sh hard


PENNER-DCNKR-02#sh hard

Cisco IOS Software, 3800 Software (C3825-IPBASE-M), Version 12.4(15)T7, RELEASE

SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Wed 13-Aug-08 23:17 by prod_rel_team


ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)


PENNER-DCNKR-02 uptime is 11 weeks, 2 days, 15 minutes

System returned to ROM by reload at 09:17:05 UTC Wed Aug 5 2009

System image file is "flash:c3825-ipbase-mz.124-15.T7.bin"


Cisco 3825 (revision 1.2) with 226304K/35840K bytes of memory.

Processor board ID FCZ131773AY

3 Gigabit Ethernet interfaces

DRAM configuration is 64 bits wide with parity enabled.

479K bytes of NVRAM.

62720K bytes of ATA System CompactFlash (Read/Write)


Configuration register is 0x2102

Peter Paluch Fri, 10/23/2009 - 02:07
User Badges:
  • Cisco Employee,

Hi Mike,


Two suggestions:


1.) Try to create a completely new Tunnel interface (Tunnel100 for example) and use the tunnel mode eon as the very first command on that interface. Only then try to add the remaining commands.


2.) I noticed that the IOS running on your 3825 is IP Base. Honestly, I am not sure if the EON encapsulation is available in the IP Base feature set. I have been using Advanced IP Services for my experiment.


Best regards,

Peter


mscomms@hotmail.com Fri, 10/23/2009 - 02:33
User Badges:

I tried 1 early on to no effect but I had noticed that it was running IPBASE as well and have just upgraded to ENTBASE and it now accepts the command, Thanks for your help


Mike

Peter Paluch Fri, 10/23/2009 - 02:47
User Badges:
  • Cisco Employee,

Mike,


You are welcome. And thanks for asking - this has been my first "exposure" to the EON type of tunnels. Thanks to you I've learned something new.


Best regards,

Peter


Actions

This Discussion