CUPC Client Issue

Unanswered Question
Oct 22nd, 2009
User Badges:

I removed a user from AD I looked in UCM the user was gone as expected and also gone from CUPS.

When I do a search in the CUPC client the user shows up as unknown. I hope someone can tell me how to get rid of this user from the client,


I tried re-syncing UCM and CUP and logged in a out of the client. This users was removed from AD a couple of weeks ago.


I am pointing my LDAP syncs to the GC port number 3268 instead of the legacy 389. I fine I get a better sync from the GC and I do not miss users in any OU.


Please help fix this because in MOC when I delete a user from AD they go away from everywhere.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htluo Thu, 10/22/2009 - 13:43
User Badges:
  • Red, 2250 points or more

There's nothing wrong with your CUPC.


When you search the user in CUPC, it's actually searching the LDAP. You may do a packet capture on CUPC computer to see the result returned by LDAP.


If LDAP returns an undesired result, you may provide the packet capture to the LDAP engineer and have him troubleshoot it. You may also post the packet capture here. I can take a look.


Michael

http://htluo.blogspot.com

dconstantino Fri, 10/23/2009 - 05:44
User Badges:

My question is why is the user gone from AD but still showing up in the CUPC client. It is not showing in UCM or CUP in the user sections. Does CUPC keep it's conacts some where else on the client PC and if so how do I purge them.

htluo Fri, 10/23/2009 - 06:26
User Badges:
  • Red, 2250 points or more

I see you already open a TAC case for it. TAC engineer won't be able to answer the question without a packet capture.


It's easy to say "it's working on computer A but not computer B". But to find out the root cause, we need something substantial like traces and packet capture.


Good luck with Bobby. :)


Michael

http://htluo.blogspot.com

dconstantino Fri, 10/23/2009 - 06:32
User Badges:

I have opened a TAC case and I am trying something. I found out this morning that the user is still in AD but disabled and moved to an inactive OU. I am having the AD admin remove the rights on those OUs from the AD accounts I use to sync with UCM and CUPS.


I also will have wireshark captures forth coming.


By the way it is an issue with all of the users not specific PCs


htluo Fri, 10/23/2009 - 06:59
User Badges:
  • Red, 2250 points or more

When I said "computer A" and "computer B", I meant CUCM and CUPS/CUPC. :)


If the deleted user was moved to a different OU, you may specify the CUPC search base. So CUPC won't search on those "Recycle Bin" OUs. It is configured from "CUPS > Application > Cisco Unified Personal Communicator > LDAP Profile".


Michael

Actions

This Discussion