Inconsistent JTAPI version between IP-IVR and CUCM

Unanswered Question
Oct 23rd, 2009


we are experiencing a problem between CUCM and IP-IVR. Each time we try to log on IP-IVR administration, we can observe a message indicating that JTAPI versions between CUCM and IP-IVR are inconsistent. We have tried to synchronize versions using synchronize task from IP-IVR administration unsuccesfully.

The IP-IVR works fine, but the message is so annoying.

Any ideas?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Ryan LaFountain Fri, 10/23/2009 - 04:13

If you are using a Linux CUCM and the associated IP IVR version for this, go to Start->Run and type 'cet'

Click No at the prompt

Click on ClusterDependentConfig

Double click on the node you are working on. Most likely the one with Key Value of 1

Click on the ClusterDependentConfig tab

Match the string next to JTAPI version to what is found in the jcu*.log in C:\

You may have multiple jcu.log files, so open up jcuCurrentLog.txt to see which one is the current log file.

It should take the form of "7.1(2.10000)-3" or similar.

Post back if you are not using a Linux version of CUCM and I'll give you the process for Windows.

antonio.vazquez Mon, 10/26/2009 - 02:09


JTAPI Version appears as Unknown and when try to resynchronize IP-IVR, I receive an error indicating that the JTAPI client cannot be resynchronized. In the JCU*.log appears the following message:

31: 2009-10-23 13:32:40.468+0200 installJtapiClient() unable to install jtapi client: installJtapiClient() Unable to install jtapi.jar in: C:\WINNT\java\lib\jtapi.jar

Is there a possibility that this is a bug in the JTAPI Installer.

I have using CUCM and IP-IVR 5.02 (SR2)




This Discussion