PAP2T firmware recovery

Unanswered Question
Oct 23rd, 2009


My PAP2T unit is blinking SOS signal which means firmware corruption. I have no web interface or IVR, but I can ping the device.

I have tried Sipura firmware recovery softwares (rec2k and rec3k) which didn't work (I get the message "Upgrade failed: Can't connect to SPA") appearantly because of their incompatiblity with PAP2.

The only software I found for PAP2 was a file posted on another thread "", but unlike the files above, this one did not include a recovery option and was only for upgrading the firmware. Upgrading failed getting the same message. I have tried using TFTP to upload the firmware, but it required web interface which I do not have.

Is there a PAP2 firmware recovery software similar to the ones available for sipura?



I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
petr_to123 Thu, 12/17/2009 - 05:06

I have similar problem with PAP2-NA. After upgrading firmware to 3.1.23 LS it worked fine until disconnecting power.
I'm getting all leds blinking SOS signal. I tried to restore unit with pap2t recovery tool, but the tool will find the unit, flash it but in the end
it says cannot connect.
Could you please attach the recovery tool for PAP2-NA unit? 

Thank you

sclimenhaga Sun, 12/27/2009 - 09:03

Ya i did the same thing upgraded to 3.1.23(LS), unplugged power last night, and now i get SOS, and yes all these recovery tools can see my device by Serial but they don't recovery as recovery tools all have wrong FW in them, please post PAP2 Recovery Tool if there is one available?


sclimenhaga Sun, 12/27/2009 - 23:29

with some help from one of the Forums i got the recovery tool for a PAP2 v1, and it worked like a dream, what i do suggest to anyone is not to UPGRADE to 3.1.23(LS) because i upgraded again and i got SOS Again, since i have the tool not a problem, so just upgrade to 3.1.22(LS) and you should have same issues again! i didn't


petr_to123 Mon, 12/28/2009 - 00:03

I didn't find any recovery tool so i wrote my own tool. Surprising it worked. I recovered unit pap2-na to version 3.1.23 (LS). But after set everything to my account the unit was broken again. So i used recovery tool again and discovered, that in default there is firmware provisioning enabled by default.

For sucesfull upgrade you have to disable provisioning and delete all lines in firmware provisioning upgrade. After that you can use new firmware 3.1.23 without any problems.

I had problems with 3.1.22, i couln't connect to my operator.

jedenjeden Tue, 01/05/2010 - 13:27

Sclimenhaga, petr_to123,

Could any of you share the recovery tool? I have the same "SOS" problem with both of mine PAP2-NA boxes... Both have 3.1.23 software and both started blinking sos after today's accidental reboot...

I cannot find the recovery tool anywhere...

Can you halp me?

makkuf_11 Mon, 05/24/2010 - 07:12


my pap2-na is in SOS mode also. I've tried your "" but it's not able to complete the uploading step. After some bytes (not a fixed value) the transfer drops.

Any idea?

Thank you.


UPDATE: with a cross cable everything goes well.

Pradeep Hapuarachchi Wed, 06/10/2015 - 18:14

Dear Sir

I used both below .


After putting S/N of the PAP2T it says NO response from SPA.

While upgrading to 3.1.6 (if I am right as the original version) to 5.1.6 suddenly power drop experienced at my home. Now it is showing RED LED for Power & Green for Netwrok/Internet LED. I still able to Ping the PAPT2T's IP from my laptop.

Any idea how to recover ?



Dan Lukes Wed, 06/10/2015 - 23:19

You should NOT use random tools found somewhere. It may brick your's device forever. PAP2 and PAP2T are not the same product. And if I remember correctly, not all PAP2T revisions are suitable for 5.x.x firmware version.

Call SMB support and ask for recovery tool for your particular device.


Dan Miley Tue, 06/16/2015 - 07:52

hi Pradeep, 

I have reached out to engineering to see if this tool is available, I'll reply to this post if I hear anything.

This device is EOL, the software isn't available for download on the software site.  The recovery tools posted above by Patrick are the only ones available currently.  This tool normally does a tftp or resynch to get the device to recover.  Unfortunately I don't have one to test.

Could you:

set a static IP on your pc (preferrably the IP address you were using for the update),   install TFTPd32 and set it to listen,  start wireshark,  boot up the pap2t,

Try the instructions from bigyanker in the first response to this post, and attempt the pap2t recovery, 

Then post the tftpd log, and  capture file (zipped probably)?


If the device is not recoverable I'd suggest a spa112 to replace it, those are supported and have many features.  Current software seems pretty stable.

There are other alternatives,   the spa232d  has a PSTN line for connecting to an analog pots provider (similar to a spa3102).  The spa232d also supports wireless dect phones (up to 5 with 10 extensions I think).


This doc has info about features, setup of the dect handsets,  screenshots, 

SPA232D & SPA302D: From Getting Started to Advanced Call Routing Scenarios - Cisco Support Community



Dan Lukes Tue, 06/16/2015 - 08:08
The recovery tools posted above by Patrick are the only ones available currently.  This tool normally does a tftp or resynch to get the device to recover.

Not as simple. For description of S.O.S. recovery protocol see S.O.S Firmware Recovery Protocol Specification

You can compile own recovery tool based on it if you are skilled programmer.


ashvin213 Sun, 10/30/2011 - 21:00

Dear Sir,

I sincerely thank you for the supported provided.

My PAP2T had a corrupt firmware for reasons unknown to me.

The recovery tool provided by you worked like a charm.

Now, the PAP2T is up and running!

Thank you Sir,


grof_mostar Mon, 01/28/2013 - 23:35

I have the same problem with the device, it will not be turned on,

telephone ga reset and I can not live anymore not to approach him.

Attached is a video with work lights.

please have help for my router?

AlexMuahaha Sat, 09/28/2013 - 06:06

Let me hug you, Joe Smith!

It is working. But i just want to add one nuance about point 2)

I didn't know exact ip address so i started WireShark, then power on Linksys, and saw string like "Who has ip address" ? That means that i have to change ip address on my windows station to

And in the wireshark you can see exact name of firmware but it can be visible in TFTP logs as you said.

One strange thing that device couldn't download firmware for a long time for some reason. The speed down to about 25 byte per second and then disconnected. I tried a few times to restart Linksys [power off/on cycle] and then it started to download firmware. I was waiting for about 30-40 minutes while it finished. And then

Voilà! The device started blinking for about 30 seconds, then it just worked as expected!

So it is good solution, because rec-pap2-3-1-22-LS.exe and rec-pap2t-5-1-5.exe don't do their work unfortunatelly.

bigyanker Thu, 10/21/2010 - 21:10

I had problems recovering from SOS with the rec-pap2-3-1-22-LS.exe, just as previous poster.

This is what I had to do to recover:

1) Install the free TFTPD from here

2) Make sure that my computer had the same IP address as when I flashed it with -23-LS.

3) Watch for about 5 min the TFTPD log window.  Then, a request for a file showed up from the SOSing PAP2.

4) Download the -22.bin (not exe) firmware from

5) Rename the -22.bin with the same name as the TFTPD had logged.

Then boom, the PAP2 was back in business with -22 firmware.

Credit goes to another person, I didn't come up with this.


This Discussion

Related Content