Trigger application step

Unanswered Question
Oct 23rd, 2009

I have a script where I've run into the 1000-step limit. Part of the script reads an XML file which can take up to 200 steps if the information isn't found. This is a good place to off-load to another script. I'm trying to use the trigger application step to execute this .aef script but I can't get the script to execute. The trigger application step always falls through to the NotFound branch. I've tried many iterations of the path to the file which does work as a stand-alone script if called via a trigger. I've used just the file name with and without .aef. I've tried the fully qualified path to the file with and without the file extension. No luck.


What's the secret to getting another script to execute from a trigger application step? The documentation is a little sparse on details and there aren't any examples that I can get to work.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bill Mungaven Fri, 10/23/2009 - 08:14

Thank you for the quick response. Please excuse my ignorance but how and where do I define the application name? Is it possible to define another script as an application? What type of application (i.e. exe?) can I define in the application name field?


I'm still new to this type of programming and I'm still learning.

Jonathan Schulenberg Fri, 10/23/2009 - 09:13

Yes you need to associate the script to an application under Applications > Application Management. The name is case sensitive when you enter it into that step.

Bill Mungaven Fri, 10/23/2009 - 20:15

Thank you for your help. That did it. Now I have to troubleshoot the errors I'm getting when executing the application script. Something about the wrong trigger type. I have to research this further but at least I can execute another script now.

brian1mcc Tue, 05/03/2011 - 01:25

Did you manage to get this working?


When using the Trigger Application step, I get an error saying

'AcceptStep: Trigger is not a ContactApplicationTrigger'

in the application being triggered.


Any ideas or examples on how to get this working would be appreciated.


Brian

Bill Mungaven Tue, 05/03/2011 - 06:41

Brian,


I gave up on this. I thought I had it working but I kept getting error messages so I gave up devoting anymore time to it. To work around the 1000-step limit I just increased the limit to 3000. I couldn't find any script examples or anyone who had actually done it who could provide guidance. Sorry.

brian1mcc Tue, 05/03/2011 - 06:46

Thanks for your reply bmungaven ...

The UCCX documentation on this is quite bad, I've tried all sorts of different things and haven't managed to get it working. I need to get it working for reporting purposes more than anything.


Has anybody had any success in using the Trigger application step?


Brian

Actions

This Discussion