CS-MARS cannot discover context on ASA/PIX 7.2.4

Unanswered Question
Oct 23rd, 2009


We are running CS-MARS 6.0.5 at customers site and trying to add one PIX 525(7.2.4) and ASA 5550(7.2.4). Adding of admin context works ok, but discovery of contexts doesn't work on either platform.

We are accessing devices with SSH access. Everything is configured in accordance with Cisco manual.

We tried to remove and add again devices, to reload MARS, to remove devices, reload MARS and add. Nothing helps.

If we try to add contexts manually, it adds them on list, and after hitting discovery again on main device we got this message:

"Child context exists for this Single Mode/Single Context Pix7/ASA device!! Please delete it"

PIX and ASA are "Security context mode: multiple ".

Any ideas?

Kind regards,



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
marko.keca Mon, 10/26/2009 - 01:20

Hello Farrukh,

Yes, we tried that procedure for several times without any success.

Yes, we configured both IP addresses and "Access Type" is SSH while adding the device.

After your message I tried to add device without Reporting IP and it worked for PIX 7.2, but for ASA 7.2 still doesn't work :(

Have you any other suggestion?

Thanks for your help!




marko.keca Mon, 11/02/2009 - 08:20


One update to this problem. Today we added ASA 5550 with 8.0.4 SW, and MARS detected all contexts without a problem.

So far only combination of ASA with contexts and SW 7.2.4, makes no context detection on MARS.

I can't find any bug related to this setup in BugToolkit.





This Discussion