PBR Query on 4507 chassis

Unanswered Question
Oct 26th, 2009
User Badges:

Dear All,


I have a 4507 chassis with dual SUP 6-E with "cat4500e-entservicesk9-mz.122-52.SG.bin" IOS image which supports PBR functionality.


now i have configured a PBR as follows:

*****************************************

interface Vlan143

description ** ACS-Backup ***

ip address 192.168.143.252 255.255.255.0

ip helper-address 192.168.0.248

no ip redirects

ip policy route-map ACS-Back


access-list 108 permit ip 192.168.143.0 0.0.0.255 172.17.90.0 0.0.0.255

access-list 108 permit ip 192.168.43.0 0.0.0.255 172.17.90.0 0.0.0.255


route-map ACS-Back permit 10

match ip address 108

set ip next-hop 20.20.20.1

exit

route-map ACS-Back permit 20

exit


*****************************************


my PBR is not working and i am getting the error message as follows:


*****************************************

Oct 24 22:21:39.823: %C4K_IOSIPROUTEMAN-3-PBRDOESNOTSUPPORTQOS: Route-map 'ACS-

Back' on interface 'Vl143' specifies Quality of Service rewriting which is not supported via Policy-Based Routing on this platform. Please use the Quality of Service feature instead. This action on the specified route map will be ignored.

*****************************************


is this possible to set the next hop address by using policy-map.


I didn't find any doc which says it is possible through policy-map and class-map.


what to do now?



plz help...




thanks

Nitin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nitsg.gupta Mon, 10/26/2009 - 00:24
User Badges:

I also got the explanation of this error.


****************************************

Error Message C4K_IOSIPROUTEMAN-3-PBRDOESNOTSUPPORTQOS:Route-map

' [char] ' on interface ' [char] ' specifies Quality of Service

rewriting which is not supported via Policy-Based Routing on this

platform. Please use the Quality of Service feature instead. This

action on the specified route map will be ignored.


Explanation This message indicates that the Catalyst 4500 series switch does not support QoS services that are implemented using PBR route maps.


Recommended Action You should configure this feature using the QoS policy maps and class maps instead. The PBR route map that is specified will be loaded, but references to QoS services will be ignored.

*****************************************

Giuseppe Larosa Mon, 10/26/2009 - 00:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nitin,

what happens if you use a standard ACL in the PBR route-map ?


it matches only source.


your configuration looks like correct with one doubt:

is the next-hop 20.20.20.1 reachable out a connected interface.

in other words

sh ip arp 20.20.20.1 provides you an entry?


the PBR chapter in config guide for your IOS image is here:


http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst4500/12.2/52sg/configuration/guide/pbroute.html#wp1026289


I've noticed that all examples use standard ACLs to match on source addresses.


But usually PBR can be used with extended ACLs.


Sup6-E support of PBR is different and recent ( in previous IOS releases PBR on this sup was not supported).


PBR is supported as far as the set action can be expressed in the TCAM table by pointing to an entry in CEF adjacencies table (that is the ARP table).

So I would say verify you have specified an adjacent IP address as next-hop.


Hope to help

Giuseppe


nitsg.gupta Mon, 10/26/2009 - 01:06
User Badges:

thanks for quick reply...



i'll check what u suggested and let you know about update...


are you aware to the 2nd reply in this post what i have posted, it is error explanation from cisco.


thanks

nitsg.gupta Mon, 10/26/2009 - 04:24
User Badges:

against your query i have checked the followings:


4507_SW#sh ip arp 20.20.20.1

Protocol Address Age (min) Hardware Addr Type Interface

Internet 20.20.20.1 223 0004.2746.89ad ARPA Vlan40





interface Vlan143

ip address 192.168.143.252 255.255.255.0

ip helper-address 192.168.0.248

no ip redirects

ip policy route-map TESTING

end



route-map TESTING permit 10

match ip address 10

set ip next-hop 20.20.20.1

!

route-map TESTING permit 20

!




4507_SW#sh access-list 10

Standard IP access list 10

10 permit 192.168.143.0, wildcard bits 0.0.0.255 (13 matches)

4507_SW#



4507_SW#sh route-map TESTING

route-map TESTING, permit, sequence 10

Match clauses:

ip address (access-lists): 10

Set clauses:

ip next-hop 20.20.20.1

Policy routing matches: 13 packets, 2666 bytes

route-map TESTING, permit, sequence 20

Match clauses:

Set clauses:

Policy routing matches: 3606 packets, 4855059 bytes




4507_SW#traceroute 172.17.90.28


Type escape sequence to abort.

Tracing the route to 172.17.90.28


1 n003-000-000-000.static.ge.com (3.1.1.2) 0 msec 4 msec 0 msec

2 * * *



and it still showing the following error


*Oct 24 22:21:39.823: %C4K_IOSIPROUTEMAN-3-PBRDOESNOTSUPPORTQOS: Route-map 'ACS-

Back' on interface 'Vl143' specifies Quality of Service rewriting which is not s

upported via Policy-Based Routing on this platform. Please use the Quality of S

ervice feature instead. This action on the specified route map will be ignored.



plz help.....


Actions

This Discussion