problem in OSPF!

Unanswered Question
Oct 26th, 2009
User Badges:

Hi all

I have meet a problem in ospf, i have two sites with 2 routers running ospf, configuration is basic, 2 router connect each other over 1 tunnel GRE. In normal, ospf is running well, but when i "shutdown" tunnel of 2 router and "no shut" it active again, but ospf is not running again, i troubleshoot and i see:

"Oct 26 01:33:52.362: %OSPF-5-ADJCHG: Process 1, Nbr on Tunnel15 from DOWN to DOWN, Neighbor Down: Ignore timer expired

:12.338: %OSPF-5-ADJCHG: Process 1, Nbr on Tunnel15 from EXCHANGE to DOWN, Neighbor Down: Too many retransmissions" . OSPF process is reaching Exchange state but it is not Fullloading. I wonder why ??

So, Everone know that is, or have the same erro, could help me


Many thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Muhammad Zeesha... Mon, 10/26/2009 - 00:42
User Badges:

This problem usually happens when OSPF Neighbors have different MTUs on the Interface on which they are trying to form the adjacency. Specify ip ospf mtu-ignore on the Tunnel Interface.


ducnv_isphn Mon, 10/26/2009 - 01:04
User Badges:

Thanks Zeeshan,

I have specify comman "ip ospf mtu-ignore" in interfaces.

I want give more information "I re-running ospf as way: use command Clear ip ospf process" after the system is running normal

So more reason, i don't know

hugh2_nguyen Mon, 10/26/2009 - 13:05
User Badges:

I had the same problem when I run OSPFv3 accross the tunnel. I had to switch to OSPFv2. Try this with the tunnel interface:

Router(config-int)# tunnel path-mtu-discovery

bapatsubodh Mon, 10/26/2009 - 13:55
User Badges:

Hi Duncv,

This is typical problem for "exchange" state of the OSPF neighbor relation ship. And answer to adjust MTU size is correct in my opinion. The thing is you need to specify it on GRE interface as well as physical interface on wihch GRE is terminating. ( on both side routers )

Try setting it to 1450. ( not 1500 ).

Clear ospf process and see if still it is getting sturck in "exchange" phase.

HTH. Rate if helps.



This Discussion