Best way to connect a simple LAN to the Internet using a 2600

Unanswered Question
Oct 26th, 2009

I am more than a bit rusty and reconfiguring a network due the arrival of a new SBS office server. The new office server needs to connect to the Internet via a Cisco 2600 router.  The server is say 10.1.1.10 and the FastEthernet interface on the router is, 10.1.1.200. The 2600 has a serial interface that is connected to a leased line with an external IP address.


So:

OfficeServer (10.1.1.10)<----->FastEthernet0(10.1.1.200)[2600 ROUTER1]Serial0(123.123.123.54)<---leased line--->ISP(Internet)


However, I also have a webserver on our office, with an external IP address from our range, that needs to, and can, see the Internet.


So, we also have, on the same router:

WebServer (90.4.123.35)<----->FastEthernet0(90.4.123.254)[2600 ROUTER1]Serial0(123.123.123.1)<---leased line--->ISP(Internet)


interface FastEthernet0/0
ip address 10.1.1.200 255.255.0.0 secondary
ip address 90.4.123.254 255.255.255.0
ip nat inside
speed auto
full-duplex
!
interface Serial0/0
description Connection to NTL
ip address 123.123.123.54 255.255.255.252
ip broadcast-address 123.123.123.55
ip access-group inboundfilter in
ip access-group outboundfilter2 out
ip nat outside
encapsulation ppp
no fair-queue


The FastEthernet0 interface has both an internet and external IP address mapped to it. Currently the office PCs use the external IP address as their gateway address and this works, however the new server is more secure and won't allow this.

There is NAT and access-lists running on the Cisco and each office PC has an internal IP address that is mapped to a dedicated external IP.


At the moment the webserver can see the Internet, but the office server cannot. So I am trying to resolve this whilst also trying to set it up better/properly.


What is the best way to do this (all assistance appreciated)?

Do I need to NAT the internal office server IP to an external IP address for it to see the internet?

Do I need to NAT the internal gateway address to an external IP address or will the router be able to route this anyhow?

Could it be DNS, so should I set the DNS server on the office server NIC to the ISPs DNS server, or to the Cisco?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
riroe Tue, 10/27/2009 - 01:52

“Thank you for your question.  This community is for Cisco Small Business products and your question is in reference to a Cisco Elite/Classic product.  Please post your question in the Cisco NetPro forums located here: http://forums.cisco.com/eforum/servlet/NetProf?page=main  This forum has subject matter experts on Cisco Elite/Classic products that may be able to answer your question.”

- Routers ----> Network Infrastructure Forum http://forum.cisco.com/eforum/servlet/NetProf;jsessionid=E0EEC3D9CB4E5165ED16933737822748.SJ3A?page=Network_Infrastructure_discussion

-



Actions

This Discussion

Related Content