Snmp Version2 on Cat 6 supported ?

Unanswered Question
Oct 26th, 2009

Hi All,

I use this H/W

System image file is "sup-bootdisk:s72033-ipservices_wan-mz.122-18.SXF5.bin"


cisco WS-C6504-E (R7000) processor (revision 2.0) with 983008K/65536K bytes of memory.


When doing snmpwalk using SNMP version 1 get response as follows:


[[email protected] cacti]# snmpwalk -v 1 -c MyString x.x.x.x .1.3.6.1.2.1.2.2.1.2

IF-MIB::ifDescr.1 = STRING: GigabitEthernet1/1

IF-MIB::ifDescr.2 = STRING: GigabitEthernet1/2

IF-MIB::ifDescr.3 = STRING: GigabitEthernet3/1

IF-MIB::ifDescr.4 = STRING: GigabitEthernet3/2

IF-MIB::ifDescr.5 = STRING: GigabitEthernet3/3

--- cut ---


But if use SNMP the version 2 , seems not responding (shown "Time Out")

[[email protected] cacti]# snmpwalk -v 2c -c MyString x.x.x.x .1.3.6.1.2.1.2.2.1.2

Timeout: No Response from x.x.x.x


Any idea is it because My Cat 6 doesn't support SNMP version 2, any advice?


Thanks&Regards,

sam

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 10/26/2009 - 19:51

SNMPv2c is supported with no additional configuration. I don't know of any bugs which would cause this. If you enable "debug snmp packet" on the device then run the test, what output do you see?

sam_manay Wed, 10/28/2009 - 22:47

Hi,

This is the current snmp config

Router1#sh ru | i snmp

snmp-server view v1default internet included

snmp-server view v1default at excluded

snmp-server view v1default ip.21 excluded

snmp-server view v1default ip.22 excluded

snmp-server community MyString1 RO 1

snmp-server community MyString2 RO 1

snmp-server community MyString3 view v1default RO 1

snmp-server community MyString4 RW 1

snmp-server trap-source VlanXX

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps casa

snmp-server enable traps tty

snmp-server enable traps bgp

snmp-server enable traps config

snmp-server enable traps dlsw

snmp-server enable traps frame-relay

snmp-server enable traps hsrp

snmp-server enable traps ipmulticast

snmp-server enable traps msdp

snmp-server enable traps rtr

snmp-server enable traps syslog

snmp-server enable traps dial

snmp-server enable traps entity

snmp-server enable traps rsvp

snmp-server enable traps envmon fan shutdown supply temperature status

snmp-server enable traps voice poor-qov

snmp-server host x.x.x.x MyString1


The backgorup of using the SNMP ver 2 is to configure our NMS-cacti in order to

support traffic monitoring more than 100 Mbps. The only solution that we need is to set snmp ver 2 ( which supports 64 bit).


Thanks&Regards,

Sam

Joe Clarke Thu, 10/29/2009 - 07:20

What community string are you using now? I would strongly recommend you remove all the v1default view customizations. If you need a custom view, create a new one. Do not override v1default.


Also, can you post the output of "debug snmp packet" when reproducing this problem?

sam_manay Thu, 10/29/2009 - 19:14

Hi,

I removed all v1 default as suggested, but snmp ver still wasn't not working.


If I issue this command:

"debug snmp packet"

How much utilization taken by this proccess?

Because the current unit is running on production.


Thanks&Regards,

Sam

Joe Clarke Thu, 10/29/2009 - 19:44

It depends on the amount of SNMP traffic the device is receiving. If a lot of polling is being done, then it can increase device load substantially.

sam_manay Thu, 10/29/2009 - 20:12

Hi,

Any other alternative solution? Since you confirmed that the current IOS is being used can still support snmp ver 2.


Thanks&Regards,

Sam

Joe Clarke Thu, 10/29/2009 - 20:33

Without seeing how the packets are being interpreted by the switch, I cannot say why this is happening. I cannot reproduce internally. You might try increasing the SNMP timeout in your snmpwalk tool. Try 10 seconds to see if it makes a difference.

Actions

This Discussion