ESW Switches and Smartports

Unanswered Question
Oct 27th, 2009
User Badges:

Hi All,


Just going through the ESW switches, and it looks like their is no option for 'Server' on these switches (I have noted this on the 2960G's as well).


Is this a shortcoming of CCA, or has this been excluded on purpose.  I know that for the 520 and 500 switches it was there.


Thanks!


Chris

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Platts Wed, 10/28/2009 - 20:40
User Badges:
  • Silver, 250 points or more

A server can actually be connected to a Smartport that does not have the server option. The UC520 and UC540 Ethernet switchports actually do not include a server option. The desktop option will really give you the functionality that you need on UC520, UC540, or ESW switchports. You can fine tune the settings in the ESW Web GUI if necessary.

CHRIS YEO Wed, 10/28/2009 - 21:26
User Badges:

John,


I do understand that you can use a server in a non server port... but based on the macro below:


Macro name : cisco-desktop
Macro type : default interface
# macro keywords $access_vlan
# desktop port role
switchport mode access
switchport port-security maximum 1
no macro description
macro description cisco-desktop
queue-set 2
service-policy input general-map
srr-queue bandwidth share  5  5 40 50
switchport access vlan $access_vlan
switchport port-security
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
spanning-tree portfast
storm-control broadcast level 10.0
cdp enable
spanning-tree bpduguard enable



And then this macro:


Macro name : cisco-server-critical
Macro type : default interface
# macro keywords $access_vlan
# server port role critical
switchport mode access
switchport port-security maximum 1
no macro description
macro description cisco-server-critical
queue-set 1
service-policy input critical-server-map
srr-queue bandwidth share  5  5 70 20
switchport access vlan $access_vlan
switchport port-security
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
spanning-tree portfast
storm-control broadcast level 10.0
cdp enable
spanning-tree bpduguard enable


It doesn't set the qos the same ways.  I assume we would have a noticable difference in speed to the server, and since the esw's are not ios, I dont' see there is anyway to set these manually.


Now I do realize that these switches are base switches, but in my opinion we are penalizing SMB with substandard options.  I got these macro definitions from my CE520-24PC.


Thanks!

John Platts Wed, 10/28/2009 - 21:55
User Badges:
  • Silver, 250 points or more

QoS configuration on the ESW 520 and ESW 540 switches is described in Chapter 12 of the ESW 500 Administration Guide. I know that the QoS for server traffic is possible to do on ESW switches, but it is not an easy one step option. Some of the server options are designed to be used in environments where Cisco Unified Communications Manager is deployed, and should not be used in SBCS/UC500 or Cisco Unified CME deployments.

John Platts Wed, 10/28/2009 - 22:04
User Badges:
  • Silver, 250 points or more

You probably do not need to do any special QoS tricks to connect servers to ESW 540 switches or to the gigabit ports on ESW 520 switches. The ESW 520 and ESW 540 switches actually prioritize voice over data. Voice only consumes about 1/1000 of the available bandwidth on a 10/100 port, and about 1/10000 of the available bandwidth on a 10/100/1000 port if a phone with a gigabit Ethernet port is used.


Currently available phones that support Gigabit Ethernet: 7945G, 7965G, 7975G

End-of-life phones that support Gigabit Ethernet: 7941G-GE, 7961G-GE, 7971G-GE


If you want to take advantage of Gigabit Ethernet, you need to use the ESW-540-24P PoE switch, or use the non-PoE versions of the ESW 540 switch and power the phones with power cubes.


You can probably get around the problem by plugging your server and your desktop computers into a ESW 540 switch. Be sure that the servers are directly plugged into the ESW 540 switch. Plug your desktop computers either directly into the ESW 540 switch, or to the PC port on a Cisco 7900 series phone that has a Gigabit Ethernet PC port (such as the 7945G, 7965G, or 7975G).

John Platts Sun, 11/08/2009 - 04:57
User Badges:
  • Silver, 250 points or more

ESW switches also have a higher switching capacity than the Catalyst Express counterparts. This means that the ESW switches can handle more traffic than their Catalyst Express counterparts.

John Platts Sat, 12/12/2009 - 13:21
User Badges:
  • Silver, 250 points or more

The Server port role will be added in future firmware releases of the ESW 500 series switches and future CCA releases. In addition, the following smartport roles will be added:

  • Printer (was available on Catalyst Express switches, and is going to be added to ESW switches)
  • Video Surveillance Camera (was not available on Catalyst switches, but is a new smartport role for ESW switches)


These new roles are mentioned in the latest version of the ESW 500 Administration Guide.

CHRIS YEO Sat, 12/12/2009 - 18:04
User Badges:

John,


I had read that in the new docs as well.


Thanks for the update for everyone else.


Chris

Actions

This Discussion

Related Content