IOS for 1841

Unanswered Question
Oct 28th, 2009

I have an 1841 which has an ADSL WIC installed and also a VPN module.

Having trouble finding an IOS that supports both the ADSL WIC and VPN.

Currently got c1841-adventerprisek9-mz.124-25b.bin on there but this does not seem to support the ADSL WIC as i get these errors and the ATM interface does not show up;

CFG-3-CARD_NOT_SUPPORTED: Slot 0: Unknown WAN daughter card, Part# 73-9932-6, HW-Rev 8.0, Board-Rev A0

Router#sh ip int bri

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES NVRAM administratively down down

FastEthernet0/1 YES DHCP up up

however this image does support the VPN

Cisco 1841 (revision 7.0) with 234496K/27648K bytes of memory.

Processor board ID FHK12102A30

2 FastEthernet interfaces

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM.

62720K bytes of ATA CompactFlash (Read/Write)

The ip_base image supports the ADSL but not the VPN....

Anyone know of an IOS that supports both?


I have also tried c1841-entservicesk9 and c1841-advipservicesk9-mz

Both support the VPN but not the ADSL module... Any help would be greatly appreciated!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Giuseppe Larosa Wed, 10/28/2009 - 01:06

Hello Luca,

I would say 12.4T advanced enteprise take one of the late ones like 12.4(20)T

check with FN as explained in other post

Hope to help


dreams_as_money Fri, 11/06/2009 - 23:01

Hi Luca

Can U tell me what ios you used?

I have the same problem tried several ios but none appreciate me


Mohamed Sobair Sat, 11/07/2009 - 02:20


The bellow image should support both:


However, If you check the feature Navigator, you will find out that the (Advance Enterprise services) does supports both also. I am wondering why your hardware couldnt identify the ADSL WIC, keep in mind the WIC could be faulty.



dreams_as_money Sat, 11/07/2009 - 02:25


ADSL iz working but router didn;t identify vpn module thats why ia have t find suitebale ios or I have to upgrade routers ram


Mohamed Sobair Sat, 11/07/2009 - 02:41


You dont have to upgrade the router ram.

You have a sufficient DRAM of 256 which is compatible with the required IOS. Try the IOS I have sent earlier.




This Discussion