4506 Switch reloads

Unanswered Question


I had a problem with a 4506 Switch version 12.2(37) SG which reloaded once, I saw in the show version output the following line "System returned to ROM by abort at PC 0x0" I tried tyo check it out within the bug tool kit and I found this bug CSCsi17158 but it says it happens in other platforms. I'd like to know if there is a document where the problem was presented with 4500 series switches and how to solve it, or if anyone knows happened and how to avoid it.

Thank you in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ZlatkoBN1 Wed, 10/28/2009 - 09:38


I had same problem today. Switch C4506-E with version 12.2(52)SG reloaded without any reason and I saw same in show version as you. He has worked corectly for about 6 months.

Lucien Avramov Wed, 10/28/2009 - 15:23

The workaround of the bug is :

Workaround: There are mitigations to this vulnerability:

For Cisco IOS, the SSH server can be disabled by applying the command crypto key

zeroize rsa while in configuration mode. The SSH server is enabled automatically upon

generating an RSA key pair. Zeroing the RSA keys is the only way to completely disable the SSH server.

Access to the SSH server on Cisco IOS may also be disabled via removing SSH as a valid transport

protocol. This can be done by reapplying the transport input command

with 'ssh' removed from the list of permitted transports on VTY lines while in configuration mode. For


line vty 0 4

transport input telnet


If SSH server functionality is desired, access to the server can be restricted to specific source IP

addresses or blocked entirely using Access Control Lists (ACLs) on the VTY lines as shown in the

following URL:



More information on configuring ACLs can be found on the Cisco public website:



This Discussion