1140n and Intel 5300AGN performance

Unanswered Question
Oct 28th, 2009

We are seeing what we perceive to be, less than optimal data throughput rates between the 1142 and the Intel 5300AGN.

Configured as follows:

WiSM w/ code



802.11b radio OFF

20MHz channels

WMM Enabled

Dell Latitude E5400

INTEL 5300AGN w/ driver (also tried and

Wireless Zero configuration


upload = 53Mbps download = 66Mbps

Same TEST with BROADCOM 1505 card:

upload = 73Mbps download = 84Mbps

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
dancampb Wed, 10/28/2009 - 12:10

Try disabling A-MPDU. There are some compatibility issues with A-MPDU between the controller and Intel clients. To disable A-MPDU you can use the following commands:

config 802.11a 11nsupport a-mpdu tx priority all disable

config 802.11b 11nsupport a-mpdu tx priority all disable

Dave_A_Baughn Wed, 10/28/2009 - 13:44

disabling the a-mpdu tx priority only decreased our performance on downloads by 25-35Mbps.

scottyschafer Mon, 11/02/2009 - 06:18

Im experienceing the same speeds however im also having cases where the clients will not pass traffic. They dont get disconnected. They just will not pass traffic for a minute or so and then pick up again. Has anyone else experienced this with the Intel 5300AGN. I have the same environment described in this post.

Robert.N.Barrett_2 Wed, 10/28/2009 - 18:35

Sorry for the dumb question, but do you have the AP plugged into a gig switch port?

What 802.11n rates do you have enabled?

What connection speed are you showing on the client side?

What OS/Service Pack is the Dell running?

How are you running your throughput test?

Dave_A_Baughn Fri, 10/30/2009 - 06:53

do you have the AP plugged into a gig switch port?


What connection speed are you showing on the client side?

144Mbps on 20MHz channel, 300Mbps on 40MHz channel

What OS/Service Pack is the Dell running?

Windows XP Pro SP2, had SP3 but left it off on this install to rule out software problem

How are you running your throughput test?


Opened a case with TAC. They tested similar setup with 5300AGN and a Linksys Dualband AGN card. I was told the results were similar to what I was seeing, that the 5300AGN was lower in connection speed and throughput.

Leads me to conclude that this is a client issue.

Robert.N.Barrett_2 Fri, 10/30/2009 - 08:03

You've obviously done your homework. About the only things I can recommend are:

- Ensure you've applied the post-SP2 wireless patch: http://support.microsoft.com/kb/893357

- Override all of the the Intel's default settings that affect 802.11n (including packet bursting!) to ensure they are set to 802.11n-friendly settings -- even if the default setting shows the desired setting.

What sort of controller are you using?

Dave_A_Baughn Fri, 10/30/2009 - 08:25

M$ post-SP2 wireless patches were installed in order to allow us to use WPA2-PSK

we've tried the client default settings and then optimized them for 802.11n.

no real change to speak of

The controller is a Cisco WiSM module in a 6509 running code. We have only two AP's on this controller, a 1252 and an 1142 (test lab environment). Of the two, the 1142 gave us the best results, but still not what we expected to see from this client.

I believe we'll just have to wait for Intel to provide the solution in an update at some future date.

Robert.N.Barrett_2 Fri, 10/30/2009 - 09:17

Thank you for reporting your results.

If you get any updates about improving the Intel speed, please post something back to the forum.


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode