QOS on portchannel on 7609 routes

Unanswered Question
Oct 28th, 2009
User Badges:

Hi all


I am trying to have the following QOS parameters applied on a portchannel interface on my 7609 router.

I am getting the below mentioned error.Any suggestions in this regard will be appreciated.



class-map match-any cos7

match cos 7

class-map match-any cos6

match cos 6

class-map match-any cos1

match cos 1

class-map match-any cos0

match cos 0

class-map match-any cos4or5

match cos 4

match cos 5

class-map match-any cos2or3

match cos 2

match cos 3

!

policy-map AAV-downlink-child

class cos7

police 2000000

priority

queue-limit 128 packets

class cos6

bandwidth percent 36

queue-limit 128 packets

class cos4or5

bandwidth percent 20

queue-limit 128 packets

class cos2or3

bandwidth percent 15

queue-limit 128 packets

class cos1

bandwidth percent 4

queue-limit 128 packets

class cos0

bandwidth percent 4

queue-limit 1024 packets



policy-map AAV-downlink-50M

class class-default

shape average 50000000

service-policy AAV-downlink-child


interface Port-channel10

description LACP Group ID 1

ip address 10.41.193.129 255.255.255.252

no ip redirects

ip ospf cost 10

mls qos trust dscp

!

interface GigabitEthernet1/6

description LACP Group ID 1

no ip address

mls qos trust dscp

channel-group 10 mode active

!

interface GigabitEthernet1/7

description LACP Group ID 1

no ip address

mls qos trust dscp

channel-group 10 mode active



Router(config-if)#int port-channel 10

Router(config-if)#service-policy output AAV-downlink-50M

shape average command is not supported in output direction for this interface

Configuration failed!

Router(config-if)#service-policy input AAV-downlink-50M

shape average command is not supported in input direction for this interface

Configuration failed!

Router(config-if)#


Kind regards

Ullas

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Edison Ortiz Wed, 10/28/2009 - 16:19
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Ullas,


You are facing a limitation on the hardware as regular line cards do not support egress shaping.


For shaping on egress, you need a WAN module (SIP/SPA or FlexWAN).


Regards


Edison.

ullasupendran Wed, 10/28/2009 - 16:46
User Badges:

HI edison


Dou you meant to say it wornt support ingress shaping too? it was not taking the service policy input also....


Ullas

Edison Ortiz Wed, 10/28/2009 - 17:33
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You aren't allowed to shape on ingress even with a WAN module. Shaping can only be done on egress. However, you can police on ingress and egress with the regular line card.


Regards


Edison.

Actions

This Discussion