Gatekeeper Registration problem

Unanswered Question
Oct 29th, 2009

Hi All,

I'm trying to troubleshoot a gatekeeper registration problem but I'm without ideas now. I have used the same configuration on 3 gateways, but one of then its not registering. On the debugs (debug RAS and debug h225 ans1) there is no reference about this gateway trying to register on gatekeeper and this debugs on the gateway nothing shows up at all (it's empty).

please, any ideas will be very appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Tommer Catlin Thu, 10/29/2009 - 11:38

Can you post a config?

Typically it is the h323 bind command is not the on the correct inferface. The interface IP address has to match the GK config for that router as well.

Guilherme Masca... Thu, 10/29/2009 - 11:52

thanks for the help.

the configuration is below... As I told you the same configuration has worked on the other gateways. Is it possible to check if for any reason the h323 bind is not working?

interface GigabitEthernet0/0.2

encapsulation dot1Q 80

ip address

h323-gateway voip interface

h323-gateway voip id GK-CTB-1 ipaddr 1719 priority 1

h323-gateway voip id GK-CTB-2 ipaddr 1719 priority 2

h323-gateway voip h323-id [email protected]

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr



zone local GK-SP-1

zone local GK-CTB-1

zone cluster local GK-SP GK-SP-1

element GK-SP-2 1719


zone cluster local GK-CTB GK-CTB-1

element GK-CTB-2 1719

This is from the gateway:

------------------ show gateway ------------------

H.323 ITU-T Version: 4.0 H323 Stack Version: 0.1

H.323 service is up

Gateway [email protected] is not registered to any gatekeeper

Alias list (CLI configured)

H323-ID [email protected]

Alias list (last RCF) is empty

H323 resource thresholding is Disabled

Non Permanent Alternate Gatekeeper List

priority 1 id GK-CTB-1 ipaddr 1719 register needed

priority 2 id GK-CTB-2 ipaddr 1719 register needed

Primary gatekeeper ID GK-CTB-1 ipaddr 1719

MARTIN STREULE Mon, 11/02/2009 - 16:27

Do you have a dialpeer with "session target ras"?

Without that it will not (try) to register.



kelvin.blair Mon, 11/02/2009 - 16:43

What do the debugs state?

debug gatekeeper main 10

debug h225 asn1

debug ras

This will tell you alot evening the address in which the request is coming from. Debug gatekeeper main 10 of course is ran on the gatekeeper. disable and reenable gateway on the remote gateway by no gateway and gateway force registration again.. Post results if possible.

Guilherme Masca... Mon, 11/09/2009 - 17:44

Thanks for for help but didn't work. I tried this command the same problem happen.

Looks like the gateway is not sending any request to the gatekeeper or this requests is not reaching the gatekeeper.

I think it is a firewall problem; How can I check that?

or maybe it's a bug on the IOS. I'm using c2851nm-ipvoice_ivs-mz.124-15.T3.bin.

What do you think guys?


This Discussion