ASDM login ( ASA 5510 )

Unanswered Question
Oct 29th, 2009

Hi Gentlemen,

I m new to ASA FW. I just tried to configure the ASA FW by using the ASDM. But I cannot lauch the ASDM login page.

I did the following procedure b4 login to ASDM page https://192.168.1.1/admin

( 1 ) ciscoasa# dir

Directory of disk0:/

61 -rwx 14635008 12:43:34 Sep 04 2009 asa803-k8.bin

2 drwx 4096 12:47:24 Sep 04 2009 log

63 drwx 4096 00:42:26 Nov 04 2005 syslog

6 drwx 4096 12:47:52 Sep 04 2009 crypto_archive

64 -rwx 5623108 13:01:34 Sep 01 2009 asdm-522.bin

ciscoasa(config)# asdm image disk0:/asdm-522.bin

( 2 ) ciscoasa(config)#http 192.168.1.21 255.255.255.255 management

( where 192.168.1.21 is laptop IP address )

( 3 ) ciscoasa(config)#http server enable

( 4 ) https://192.168.1.1/admin ( to launch the ASDM page using IE , mozilla, and made sure Pop Up is enable and java is enable)

I got the error " Web page cannot display " HTTP 404 error.

Kindly look at my ASA5510 as per attach.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nay Myo Tun Fri, 10/30/2009 - 02:40

Hi,

I even can telnet to the mgmt interface using 443.

Just tried "crypto key generate rsa mod 1024"." Same result.Thx.

mkharban Thu, 10/29/2009 - 11:33

Hi,

Can we get the output of the following:

debug http 255

Java logs from the machine on which we try and access ASDM.

Regards,

Manish

Nay Myo Tun Fri, 10/30/2009 - 02:37

Hi ,pls.take a look at the output.

ciscoasa# debug http 255

debug http enabled at level 255.

ciscoasa# HTTP: processing GET URL '/admin' from host 192.168.1.21

HTTP: redirecting to: /admin/public/index.html

HTTP: processing GET URL '/admin/public/index.html' from host 192.168.1.21

HTTP: authentication not required

HTTP: file not found: public/index.html

mkharban Fri, 10/30/2009 - 11:04

Hi,

Please visit the following url and download asdm 6.2(1) version:

http://www.cisco.com/cgi-bin/apps/tblbld/tablebuild.pl/asa

Please upload this file to flash and enter the following command on the firewall:

asdm image flash:asdm-621.bin

For uploading the file to flash please follow the procedure as mentioned in the below given link:

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008067e9f9.shtml#maintask2

This should fix the issue.

Regards,

Manish

Nay Myo Tun Thu, 11/05/2009 - 19:51

Hi Gentlemen,

I ve manged to get the ASDM6.2 and uploaded it to the device and now able to access the device using the ASDM.

Really appreciate your professional advise.

Pravin Phadte Mon, 11/02/2009 - 06:30

You need to have Device Manager Version 6.1(5)

Upload this image of asdm and

config t

no asdm image disk0:/asdm-522.bin

asdm image disk0:/asdm-615.bin

Reload the Firewall.

Also see that your java is updated.

Actions

This Discussion