Cisco Unity

Unanswered Question
Oct 29th, 2009

Receiving an error in Cisco Unity.

"The Cisco Unity service that monitors Actiev Directory (AvDSAD) cannot modify the location object default in the domain (domain). This service must perform a full synchronization cycle with the domain controller (domain controller) before changes will be synchronized correctly. A full syncrhonization cycle will occure in approx 2 minutes."

We recently upgraded our domain controller to 2008. Is this a permission problem or is there somewhere I can go to perform a synchronization?

Thanks for your help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Bradford Magnani Thu, 10/29/2009 - 06:33


The DC/GC Reconnect Settings tool in the Tools Depot under Administration Tools will allow you to perform a resync for both the DC and the GC.

Hope that helps,


brian.fleishman Thu, 10/29/2009 - 09:55

Thanks for getting back to me Brad.

I was able to find that however it will still error out. Are there any compatibility problems with Server 2008 AD?

Ginger Dillon Thu, 10/29/2009 - 12:36

Hi -

What version of Unity are you running? See this info - You must install Cisco Unity 7.0 Engineering Special 7 or later on the Cisco Unity server in the following instances:

-When the Cisco Unity server is a member server in an Active Directory 2008 domain.

-When Active Directory objects for Cisco Unity subscribers, contacts, distribution lists, or locations were created in an Active Directory 2008 domain.

Engineering specials are available at (From the Downloads page, expand Unified Communications Applications > Voice Mail and Unified Messaging > Cisco Unity, and click Cisco Unity Version 7.0 > Unity System Software.) - See the ES21 Rollup in the Downloads for Unity 7 - included in there.

I believe there is also one for Unity version 5.X.


jrandall2 Tue, 11/10/2009 - 12:15

I am also getting this problem.

I have ES21 applied, and have re-run the permission wizard and granted permissions to the root of the domain. I still get this issue.

Ginger Dillon Tue, 11/10/2009 - 14:45

Hi -

Attaching this link to help clarify the Location Object -

When Unity is installed, there is an OU created in AD called Unity that contains the server's location. Make sure your permissions wizard running at the root includes this OU. Also, group policies can be applied at OUs which can explicitly deny permission down the chain. You might check that OU with your domain admins. There is an executable you can run logged onto the Unity server from command line called gpresult. You can log onto the server using the unitydirsvc account for this command, which will tell you what domain level policies have been applied (the default is to show both user and computer policies).


jrandall2 Tue, 11/10/2009 - 15:07

I have run the permissions wizard and granted it to the unity, unity/locations and / contexts.

I have run gpresults and found the policies in effect. I have review the settings applied to the machine and have not noticed a setting in group policy that would prevent inheritance of permissions of a ou object.

Hoan Mai Tue, 11/10/2009 - 15:01

Make sure that you run the AD 2008 XML Test since it's AD2008.

Check the CCO for the download.

It should be in the ES21 Rollup in the Downloads for Unity 7.

jrandall2 Tue, 11/10/2009 - 15:02

Yes, I ran the test and didn't notice any negative results.

brian.fleishman Wed, 11/11/2009 - 05:58

You are still getting the error? I was able to resolve my problem by going to another 2003 DC, instead of the 2007. What exactly do you have for your permissions?

jrandall2 Wed, 11/11/2009 - 09:17

Yes I am still getting the error.

The unity permission wizard runs without issue. it grants all the accounts the correct permissions. doing a spot check in the domain I see the unity directory service account has full permissions to the unity/locations objects...

I dont have any remaining 2003 dcs. and using a 2003 dc isn't really a solution, that's rolling back.

brian.fleishman Wed, 11/11/2009 - 09:28

What errors are you getting in event viewer? Check your DCGC reconnect settings tools. Verify the Domain Controller and the Global Catalog server. You can also check the DohPropTest.exe stored on the commserver\tech tools\. Check the AD monitor so make sure the correct. Verify the DC server is set and try a totalresync, after a total resync, restart the services and try the permissions wizzard again.

jrandall2 Mon, 11/16/2009 - 08:43

Event Type: Error

Event Source: CiscoUnity_DSAD

Event Category: Error

Event ID: 1073

Date: 11/16/2009

Time: 8:41:10 AM

User: N/A

Computer: UNITY


The Cisco Unity service that monitors Active Directory (AvDSAD) cannot modify the location object default in the domain vieuxcarre.local. This service must perform a full synchronization cycle with the domain controller amanda.vieuxcarre.local before changes will be synchronized correctly. A full synchronization cycle will occur in approximately 2 minute(s).

I've done all the dc and gc checks and total resyncs. Nothing helps so far.

jrandall2 Mon, 11/23/2009 - 12:04

Apparently Active Directory 2008 R2 is NOT supported yet and that appears to be the source of my issues.


This Discussion