Routing Access Layer Switches

Unanswered Question
Oct 29th, 2009
User Badges:

I have a question about routing an access layer switch rather than trunking. Like the old WAN config, I setup a stub network between routers. This is the same for switches? So, in my configuration, I would need a stub network between the access layer switch and the distribution layer switch.


Example: The access layer switch network is 192.168.15.0/24 config on ports would be:


Access switch:

interface TenGigabitEthernet1/0/1

no switchport

ip address 192.168.60.74 255.255.255.252


Distribution switch:

interface TenGigabitEthernet1/1/8

no switchport

ip address 192.168.60.73 255.255.255.252


No better way to do it? And say I want redundant links, I use another stub network on different ports?


BTY: This works in test. Making sure I'm not missing something here.


Thanks!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 10/29/2009 - 10:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Alan,

if you have a routed access layer you will have L3 (up)links as the one that you have described in your post.


The alternate way to do this is to use SVIs that would allow you to use multiple L2 links, either bundled or not


vlan 333

name bbone vlan


int vlan 333

ip address 192.168.60.74 255.255.255.252

no shut


int te1/0/1

switchport

switchport mode access

switchport access vlan 333

channel-group 2 mode active


int te1/0/2

switchport

switchport mode access

switchport access vlan 333

channel-group 2 mode active


this would allow you to have a L3 link running over a bundle of 2 TenGiga


be aware that L3 links allow you to have multiple parallel links so you can go on with routed ports but you can deploy multiple links in parallel


Hope to help

Giuseppe

Lucien Avramov Thu, 10/29/2009 - 10:50
User Badges:
  • Red, 2250 points or more

I dont like the idea of access vlan on port channel.

You should give an ip address to your port channel interface and bundle your links.


You can assign a port channel interface to a vlan, but dont do it on the interface itself as in this example.

alandean Mon, 11/02/2009 - 13:06
User Badges:

Thanks, this makes sense.


I can do port-channel on the access layer switch. Howver, the uplinks go to 2 separate distribution layer switches where I could not port-channel ports on separate switches.


Unless I have VSS on the distribution layer switches, correct?

alandean Thu, 10/29/2009 - 16:16
User Badges:

Thanks for the information!


One other scenario I'm facing is that I will be routing between 2 redundant 6500 core switches to a production network with another 2 6500 core switches.


The new production core switches have VSS and I can configure a port channel across switches.


My existing core switches are not VSS capable yet. I assume port channeling with 2 separate core switches is not possible.


Thanks again!

thilo schueler-mach Thu, 10/29/2009 - 17:24
User Badges:

Hi Alan,


could you provide more details about the C6500 routing?

If you have a fullmesh, ospf is fine.

If you have a ring topologie and don't like dynamic routing but SPT, just use VRRP or HSRP.


regards

Thilo

Rolf Fischer Thu, 10/29/2009 - 11:03
User Badges:

Hi Alan,


if you want to implement a L3-access design, there are some recommendations:

- implement OSPF or EIGRP

- use stub areas

- implement summarization

- implement equal cost routing for your uplinks

- tune routing-protocol timers to achive very fast convergence


Here's a link to the Solution Reference Network Design - very comprehensive material:

http://www.cisco.com/en/US/docs/solutions/Enterprise/Campus/routed-ex.html


HTH

Rolf

thilo schueler-mach Thu, 10/29/2009 - 17:10
User Badges:

Hi Alan,


here an other solution to address your "routing an access layer switch" problem.


At the access layer switch create a vlan, a svi with ip address and two native ethernet uplinks based on FlexLink. With FlexLink, only one link is active, one is in standby, SPT is disabled on both interfaces.


al-switch:

vlan 10

name access-vlan


interface vlan 10

ip address x.x.x.x y.y.y.y


interface g1/0/1

switchport mode access

switchport nonegotiate

switchport access vlan 10

switchport backup interface g1/0/2


interface g1/0/2

switchport mode access

switchport nonegotiate

switchport access vlan 10


FlexLinks are possible at C2960 and higher.


And here the aggregation switch/switches config:

ag-switch/switches:

vlan 10

name access-vlan


interface vlan 10

ip address x.x.x.x y.y.y.y


interface g1/0/1

switchport mode access

switchport nonegotiate

switchport access vlan 10

( inter g1/0/2

switchport mode access

switchport nonegotiate

switchport access vlan 10 )


regards

Thilo


Actions

This Discussion