Cisco Linksys WRVS4400 QuickVPN and Windows 7

Unanswered Question
Oct 29th, 2009

I own a Linksys WRVS4400 and have used it for sometime with the QuickVPN client.  I have now added two computers running Windows 7, a 32bit and 64bit version.  I am running the latest versions of firmware and QuickVPN software but can not get it to connect in Windows7.  The software will load but hangs at "Verifying Network" before it times out.  I realize that I am not the only person with this issue and am a little concerned that Cisco does not offer a version that is Windows 7 compatible.  This is a critical issue and may cause me to investigate other hardware options. 

Is it possible to use a third party client to connect to the router though QuickVPN?  Is there possibly a beta version of a new Cisco client that may work with Windows 7?

Any help or guidance would be greatly appreciated.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jestowe Fri, 10/30/2009 - 00:50


Thank you for visiting the Cisco Community Forum,

If everything has been working correctly until the installation of Windows 7, it may be related to the Windows firewall blocking ICMP requests directed at that PC.

Here is a quote on allowing PING to the PC:

"Control Panel --> System and security --> Windows Firewall --> Advanced settings --> Inbound rules --> New rule --> custom rule

in Protocol and ports: Protocol: ICMPv4
on the same panel go to customize, choose "Specific ICMP types", check the box "echo request"

next... next... and save it."



macbeck22 Fri, 10/30/2009 - 11:26


I raelly appreciate your quick response to my question.  I went through the steps to create the new rule on my Windows 7 PC.  I am able to ping my domain as I was always able to.  When I open the QuickVPN client (v1.3.0.3) it will be connecting but always hangs at "Verifying Network".  Should this version work with Windows 7?  Looking at other posts such as;jsessionid=C06B7E323D68B806A665A070F2790101.node0 it seems that the client may not work.



rdeyoungaia Sun, 11/15/2009 - 19:56

I am using Norton Internet Security 2010 for my software firewall, not the native firewall in Windows 7.  Can you recommend what I need to set up in NIS 2010?

This had been working fine from my XP laptop, but since installing Win7 on the laptop, I get the same problem described here.  The router shows it as connected, but the client Win7 laptop is hung on "Verifying Network".  Then "the remote gateway it not responding.  Do you want to wait."  If you say yes, it continues to hang on "verifying network".

David Carr Tue, 11/17/2009 - 08:59

As far as your situation at the moment, Cisco does not support Windows 7 with the quickvpn utility.  Have you tried the fix that was posted previously to your post and give that an opportunity to work.  At the moment I don't have an ETA  on when windows 7 will be supported with the quickvpn utility.

David Carr Thu, 11/19/2009 - 09:23

Yeah i apologize, but as of yet we don't have the quickVPN working with windows 7.  We are waiting for the design team to release the firmware.  Sorry for the inconvenience.

rdeyoungaia Fri, 11/20/2009 - 18:58

Is there some way we will be notified when support for Win7 will be available?


David Carr Tue, 11/24/2009 - 08:20

Check the forums or the cisco site for an update.  I am sure someone will state something on the forum about the release.

seanbdavis Wed, 12/09/2009 - 20:30

When is Cisco going to get a clue a start supporting 64bit, it's not a passing fad.

MityMarkTaylor Sat, 12/19/2009 - 20:18

What is the ETA on when it WILL be working?  I really need it to be working before January 2010!!! Is there a possibility of having an updated firmware for the RVS4000 router (and all other small business routers) that works with the native Windows 7 VPN networking?

ingerdave Tue, 01/19/2010 - 06:22

I'm bumping this to get an update.  I have Win7 64 bit and can't even run the installer for QuickVPN.  This is my last app that's causing me to hold onto an XP VM for the sole purpose of being able to VPN to my home network.

Otherwise, can someone provide a workaround or alternative VPN app that I can use on Win7 to get into my 4400 VPN router?

David Hornstein Sat, 02/06/2010 - 22:39

Hi guys,

Check out this posting as well.  Well worth a look at using the native IPSec client in windows 7.  Just wish I had a powerful enough PC that would accept  windows 7 so i could validate the procedure in the posting below;  Even though the posting mentions RV042, it sure is worth a go to try it for the WRVS4400N

Steven DiStefano Wed, 02/24/2010 - 10:55
The New Quick VPN  client version has been posted to the Cisco Software  Center.
Support for Windows  Vista and Windows 7 (32-bit and 64-bit) is available in this  release.
Users can download  the new client software by creating a CCO  account on
The Free and  Anonymous downloads will be available in the next few days.
rdeyoungaia Wed, 02/24/2010 - 16:36

Thanks, the link helped find it much easier.

Unfortuately, I installed it and have the exact same results as I did with 1.3x on Win7 Pro.

It seems to connect OK, but hangs on remote gateway not responding.  The following comment is in the PDF that came with the download, however, I can't ignore it and use the connection.  If I say "no", it disconnects, if I say "yes" and try to run a remote desktop session, it can't connect.  This is exactly the situation with 1.3x.  I have double checked my Norton Internet Security setting and it appears to be set to allow all.  Any ideas on how to get this to work??



While a QuickVPN tunnel is connected, the following message may appear:

"Remote Gateway is not responding, do you want to wait?" This issue occurs

when the remote QuickVPN Server is not responding to the ping sent by the

QuickVPN Client. This issue may be caused by the remote QuickVPN Server

temporarily overloaded. Users can ignore the pop-up message as long as the

traffic continues to flow through the tunnel.


alexander.lindqvist Fri, 02/26/2010 - 06:44

I can confirm also that QuickVPN does not solve the problem on clean Windows 7 install.

Still get remote gateway does not respond while verifying network.

XP SP3 pc on the same network can connect just fine to remote RV042 (latest firmware). Windows firewall off on windows 7 pc.

Can someone at Cisco confirm that this is still a problem with the new version of QuickVPN?

Te-Kai Liu Fri, 02/26/2010 - 08:14

Windows 7/Vista firewall has to be enabled. This is noted in the release notes.

rdeyoungaia Fri, 02/26/2010 - 08:52

I am running Norton Internet Security 2010; it takes over and doesn't allow turning on Windows firewall.  This set up worked fine with XP.

Can you please provide instructions on what settings need to be changed in NIS to make QVPN work?  I can't be the only person using NIS 2010.  It seems to be set up to allow QVPN with a very wide open rule.  It allows any direction in/out, any computer, allcommunications and any protocol.  What more could we need to set??



Te-Kai Liu Fri, 02/26/2010 - 09:09

Does QuickVPN work if you temporarily disable Norton?

From protocol perspective, QuickVPN makes use of SSL (TCP port 443 and 60443), IKE (UDP port 500 and 4500), ESP, and ICMP. You need to make sure the third-party firewall is not blocking any of the above.

QuickVPN Client also depend on several .exe programs (see attached screenshot) that are located in the QuickVPN install directory. The third-party security software also needs to trust them in order for QuickVPN to work.

wtbrowne47 Sun, 02/28/2010 - 17:18

I have the same problem with Norton Internet Security 2010.  On Vista, I can turn the Windows firewall on at the same time as the Norton firewall is on and active.  On Windows 7, Norton takes control of the Windows firewall and does not allow you to turn the Windows firewall on whether the Norton firewall in active or disabled.  It would appear that Norton would have to be uninstalled to enable the Windows firewall.

With Vista, I can make a QuickVPN connection with the remote router when both the Windows firewall and the Norton firewall on.  I am not able to make a connection with Windows 7.  Most likely because I'm not able to turn the Windows firewall on.  I really don't want to uninstall NIS 2010 just to make the VPN connection with Windows 7.

Te-Kai Liu Sun, 02/28/2010 - 20:18

If QuickVPN Client is installed on Windows 7 before Norton Internet Security 2010 is installed, I found QuickVPN Client can work properly while NIS takes over Windows Firewall. Perhaps you could try uninstalling NIS and then re-installing it.

wtbrowne47 Mon, 03/01/2010 - 06:12

Thank you.  I will try that later today and see how it works.  I'll report back on my findings.

wtbrowne47 Mon, 03/01/2010 - 09:25

OK - I uninstalled Norton Internet Security 2010 and rebooted the Windows 7 PC.  I then uninstalled QuickVPN and reinstalled it.  I verified that Windows firewall was ON and opened QuickVPN. QVPN tries to connect but then displays the message "Remote  Gateway is not responding, do you want to wait?"

I'm not sure what to do at this point.  I have not reinstalled NIS yet, I would like to make the connection without any type of internet security before reinstalling.  I have successfully connected to the QVPN using a Vista 64 bit PC after trying with Windows 7 above.

Mikezyzni Mon, 03/08/2010 - 17:30


   Did you find that this worked once you turned on the Windows Firewall?    I'm troubleshooting the problem with Symantec Endpoint Protection and after uninstall and starting the standard windows firewall QuickVPN still does not work with Windows 7.   I wonder if there is a problem with the rules after SEP is installed but Would like to verify that someone got Windows 7 clean install to work with QuickVPN.

Thank you,


alexander.lindqvist Mon, 03/08/2010 - 23:17

No did not get it to work.

I also now have a VISTA SP2 pc where NIS was uninstalled. This one also refuses to connect with the usual

"Remote Gateway is not responding, do you want to connect".

Tried NIS removal Tool.

VISTA firewall on and off.

XP pc's just works..

tlelegard Tue, 03/09/2010 - 11:44

Hello all,

Firstly, sorry for my English.

I post this message here because in seeking a solution to the problem mentioned here.
I found that the problem came from ipsecand I finally found a solution.

You must install the vpn client on windows XP export the ipsec configuration via ipsec.msc in
quickvpnclient directory and import within windows seven client.

For me, it works, i hope this info will be useful.

best regards,

pocketitguy Sat, 10/31/2009 - 12:37

While the current Cisco QuickVPN Client ver. appears to be incompatible with Windows 7, a simple workaround to resolve this problem is to change the Compatibility mode for the Cisco QuickVPN Client in Windows 7.

To do this, follow these steps:

  1. Right click on the QuickVPN Client icon and select Properties from the drop down menu.
  2. Click on the Compatibility tab in the QuickVPN Client Properties window.
  3. Check the box for the option Run this program in compatibility mode for:
  4. Select Windows Vista (Service Pack 2) from the drop down menu.
  5. Click OK.

That should do it, and your Windows 7 clients should be able to connect. This problem specifically resolves the problem with the client under Windows 7 where the log file indicates the following errors after [STATUS] Verifying Network.

[WARNING]Failed to ping the LAN IP of the remote VPN Router!

[WARNING]Ping was blocked, which can be caused by an unexpected disconnect.

Good luck.


Mikezyzni Tue, 03/09/2010 - 20:58


  That's a very ingenuous solution!  Were you able to do any analysis of the ipsec configuration to determine the key settings that are needed?   I'll take a look at it and see if I can isolate the problem by looking at the changes from the imported configuration.

Thank you,


tlelegard Wed, 03/10/2010 - 14:43

I forgot to mention that this solution works in XP mod and if only the strategy that has been imported from windows xp pc that itself has been connected once to the gateway. And I only exports FreeSwan strategy. I agree that it is a Ingenuous solution, but it works temporarly.
After looking a little more the ipsec configuration, I noticed that the security policy ipsec in firewall console was not enabled when the connexion is established. After enable this, everything works properly.

Thank you,

wmelville Thu, 03/11/2010 - 08:41

Can you please provide the steps you performed to accomplish this?  I have been trying to figure this out for awhile now, and if you have a solution I would be very grateful.

Thank you

marek_gernat Wed, 05/19/2010 - 11:18

Install QuickVPN client ,dont change compatibility mode..
Make sure the Windows 7 firewall is turned on.
Restart your computer then:

1. Right click on Computer Icon
2. Select Manage
3. Select Services and Applications
4. Select Services
5. Sort by Name
6. Look for and right click on IKE and AuthIP IPsec Keying Modules (Should not be disabled, if so, do the rest below)
7. Select Properties
8. Make Startup Type be: Automatic
9. Restart PC and try QuickVPN..

rdeyoungaia Wed, 05/19/2010 - 15:21

Just checked.  It is not disabled, but QuickVPN still fails.

It really would be nice to be able to use QuickVPN again; it is the whole reason I purchased this router.


austinm22 Sun, 05/23/2010 - 00:34

Has anyone figured this out yet? I'm ready to look for a different vpn...


Te-Kai Liu Sun, 05/23/2010 - 08:55

Have you contacted SBSC? They can help troubleshooting and determine whether it's a client-side issue or router-side issue.

WalidMagd Fri, 05/28/2010 - 11:38

It is crystal clear that Cisco is taking their clients for granted. I can’t believe a very common and urgent problem like this is not addressed yet. I am wasting tens of hours trying to get this thing to work with no luck (yes, luck became the only non-technical option left) No more. Here is what I am going to do; I will throw this piece of useless hardware – WRVS4400N – in the junk pile where it belongs, find another solution from another company who has more respect for their customers and save myself some frustration. Good bye

streaves Fri, 05/28/2010 - 13:54

I've been re-reading this thread and want to thank all who have posted. These are complex issues and I assure you the Small Business Routers team is working diligently to identify root cause and resolve. We need your help, though. If you haven't already called the Small Business Support Center, please do so right away.

Small Business Support Center -- 1 866 606 1866

Support is available 24/7 for customers in US/Canada. You'll find International Support numbers here:

Thanks again for your post and special thanks to those of you who have worked with the Small Business Support Center to help us resolve the issues.

Stephanie Reaves

Small Business Technology Group

rdeyoungaia Fri, 10/01/2010 - 06:28

For a variety of reasons, I was never able to take the time to work this out with Tech Support, but I have resolved the problem as follows.

Unfortunately, I changed several things at once, so I am not sure which one solved it or if it was the combination/sequence that did it.

First, after renewing my Norton Internet Security, they gave me a deal I couldn't pass up to add Norton Utilities.  After running the registry cleaner a couple of times, I found that several nagging problems were resolved; this was NOT one of them.

However, I thought that maybe if I uninstalled QuickVPN, ran the registry cleaner, rebooted, then reinstalled QVPN, maybe that would work.  I did that, but before reinstalling, I checked the Cisco small business website and found a slightly newer version of QVPN v1.4.1.2 and downloaded it.  After uninstalling, running the registry cleaner, rebooting, then installing v1.4.1.2, IT WORKS in Win7!!

I have no idea if any one step would have worked alone or if it took the particular sequence, but this is what solved the problem for me.


streaves Fri, 10/01/2010 - 08:18

Richard -- Thanks a lot for the update and sharing your solution.

Have a great weekend.

Stephanie Reaves

Small Business Technology Group

wtbrowne47 Fri, 10/01/2010 - 20:23

I downloaded this new version,, and I does indeed work with both Windows 7 and Vista.  I'm very happy to have this working at last!

Eric Moyers Fri, 10/01/2010 - 13:32

The major piece in this was downloading and installing QVPN Like you stated, it is a slightly newer version of QVPN. This version is the only one that I am aware of that supports Vista and Windows 7. This includes the 32-bit and 64-bit version of that OS. XP of course is supported also.

Eric Moyers
Cisco SBSC Network Engineer

austinm22 Fri, 10/01/2010 - 23:11

I downloaded the QVPN software. It still did not work with windows 7, but I am using a WRV54G router. Should it work with this old router or should I upgrade to the WRVS4400. The QuickVPN client is running on a Fujitsu UH-900 pocket-pc running windows-7.



Te-Kai Liu Sat, 10/02/2010 - 10:41

The firmware of WRV54G has not been kept up to support QuickVPN Client on Windows 7 or Vista.

austinm22 Sat, 10/02/2010 - 13:46

Hmmm... Looks like there is a WRVS4400N V1 and V2 hardware version. Which one works or are both okay?



Eric Moyers Mon, 10/04/2010 - 07:28

Most definitely go with Version 2. Newer Hardware and better performance.

Eric Moyers
Cisco Small Business Support Center Network Engineer

siradude1 Wed, 01/05/2011 - 13:09

Well this is what I've found so far.

I have 2 PC's with Windows 7 one with Ultimate and the other Home.

The Ultimate PC Connects to the router (ver2.0.8) with the lates Quickvpn software just fine.

The Other Will time out and give the Gateway not responding error...

What I can see diferent is that the PC (Ultimate) that connects fine. when the QuickVPN software is going through its pases and show a popup stating "Activating Policy" a new policy is created in the Windows Firewall under "Advanced/Connection Security Rules" named "IPsec_Tunnel" and the PC that will not connect this rule is not created.

Maybe this can guie someone to solve this.

imantspetrovs Fri, 05/20/2011 - 23:13

I also had similar problem with quickvpn version I solved it in such way: for application I checked in "Run this programm in compatibility mode" and set "Windows XP (Service Pack 3)"

abclaboratories Thu, 08/18/2011 - 00:43

Just want to confirm that quickvpn version does work with Windows 7 Pro 64bit. I do not need to set it to run in Windows XP SP3 compatibility. Latest QuickVPN always gives me "Remote Security Gateway is not responding" issue.

damiandowell Wed, 08/24/2011 - 10:58

I am also having the same issue. I have the latest firmware on my WRV4400N and have tried both and vpn clients on both win 7 ent 64, win 7ent 32, and win 7pro 32 and I cannot get it to work on any of them. My firewall is turned on and IPsec and IKE services are started

I have also tried running them in vista sp2 and xp sp3  compatability mode but this also didn't work.

I have tested on a xp sp3 station and it connected without any issues so I know my isp, and remote network is not blocking any needed ports.

Any help on resolving this issue would be great as I ordered this router specifically for the VPN use.


abclaboratories Wed, 08/24/2011 - 11:05

Hi Damian,

Is there a period "." in the user name? I found that QuickVPN could not establish a connection if there was a period "." in the user name. Once I removed it, I was able to make a connection.

This issue didn't exist on XP SP3.


This Discussion

Related Content