Cisco 800 Router NAT Loopback

Unanswered Question
Oct 30th, 2009

G'day Experts,

I have a private network: 192.168.1/24

I have a single public static IP address from my ADSL ISP.

I have a server which hosts a DNS with a private address 192.168.1.10 in my private network.

I have created a NAT 1:1 to my private server 192.168.1.10 to my public IP.

The requests from the internet work fine, my DNS resolve to my public IP address fine.

BUT

Requests from my private network 192.168.1/24 point to my public IP address which my router does not loop back through to my server.

I know a lot of routers/gateways support this feature, I just can't get it to work on my 800 series

Any assistance apreciated.

Cheers,

Arthur.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
thotsaphon Fri, 10/30/2009 - 10:51

Arthur,

It won't work in this case when private network tries to connect the IP of the DNS that is your public IP address on your router. The router won't do a static nat back to the 192.168.1.10. Because the requesting packets are not coming from the outside interface(Internet interface). In case of ASA firewall, it has a dns doctoring to solve this problem. I have never seen any feature on the cisco IOS to do this. What about setting the dns with the private IP address for internal users? (grin)

HTH,

Toshi

Arthur_Mino Fri, 10/30/2009 - 17:17

G'day Toshi,

I have this config file from a Cisco 800 series which was doing it, I just can' tell how. I have a couple of these Routers at clients places setup by their ISP's that do it.

I refuse to think you can't do it with IOS, so many home brand router/gateways support this feature.

Any assistance very much appreciated.

Cheers,

Arthur

Actions

Login or Register to take actions

This Discussion

Posted October 30, 2009 at 7:53 AM
Stats:
Replies:2 Avg. Rating:
Views:711 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,155
3 7,745
4 7,088
5 6,747
Rank Username Points
140
80
78
69
40