Modular IOS Upgrade Help

Answered Question
Oct 30th, 2009

Hi,

We are running Advance IP services 12.2 (33)SXI IOS modularity on Sup-720 on 6500. I need to patch the IOS due to IOS vulnerability. When I look for patch, there is none for SXI. In order to upgrade to the latest SXI2a version, do I need to go thru the entire modularity install again or somehow I can patch it to SXI2a without taking down the entire box?

Thanks!

I have this problem too.
0 votes
Correct Answer by Reza Sharifi about 7 years 1 month ago

Hi KEVIN,

There is no patch for it. You have to install a new IOS. I just upgraded 60 6500 switches, because of bugs in SXI2 that would cause the switches to reboot every 2 weeks. But before you upgrade, make sure you read about this bug (CSCsv30540). This specific bug still exists in SXI2a, so I had to convince Cisco IOS BU to add a bug fix for this version before I put it on my boxes.

Good luck and let me know if you need more info

Reza

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Reza Sharifi Fri, 10/30/2009 - 14:30

Hi KEVIN,

There is no patch for it. You have to install a new IOS. I just upgraded 60 6500 switches, because of bugs in SXI2 that would cause the switches to reboot every 2 weeks. But before you upgrade, make sure you read about this bug (CSCsv30540). This specific bug still exists in SXI2a, so I had to convince Cisco IOS BU to add a bug fix for this version before I put it on my boxes.

Good luck and let me know if you need more info

Reza

kevin.hu Wed, 11/04/2009 - 13:51

wow, that's good to know. I am running SXI and it has been good for me for a year now. I think I will convince the management to delay this IOS upgrade.

Actions

This Discussion