1131 and 1141 APs not finding the controller

Unanswered Question
Oct 30th, 2009
User Badges:

We have deployed about 40 of these and about half have found the controller. The others have not. I have used option 43 in the past but lately they were able to find the contrller without that. I also took out the lwapp-controller name out of dns as we have 4 buildings of these etc. Should I put the controller name in dns and what is that default name.


thanks

Gary

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
william.hostetler Fri, 10/30/2009 - 17:08
User Badges:

In the logs I have a bunch of AP not joined message with the "Number of message retransmission to the AP has reached maximum" message. It has an ip address which I can ping so it is still there.

Robert.N.Barrett_2 Sat, 10/31/2009 - 05:19
User Badges:
  • Bronze, 100 points or more

If the AP's are not on the same subnet as the controller, and you are not using Over the Air Provisioning, then you need to use DHCP Option 43, put your DNS entry back in, or set the controller address manually via the console port on the AP.


The host name for the DNS entry is CISCO-LWAPP-CONTROLLER. If you're adding that entry, then you might want to also add CISCO-CAPWAP-CONTROLLER pointing to the same address. While I believe that all current AP's will try to resolve CISCO-LWAPP-CONTROLLER (even if they are CAPWAP APs), this may not be the case in the future.


We use the DNS feature and then set the AP's appropriate primary/secondary controller after it joins.


Here's a good article about the AP join process:

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a00806c9e51.shtml


Here's a good article about troubleshooting AP's that won't join:

http://www.cisco.com/en/US/products/ps6366/products_tech_note09186a00808f8599.shtml


william.hostetler Sat, 10/31/2009 - 06:22
User Badges:

thanks for your links. These are in the same subnet and are already mounted in the ceilings. I may try putting the controller at version 4 and letting them get in and then do the upgrade process to 6. Weird that some got in and some 100 feet away did not.


Gary

william.hostetler Mon, 11/02/2009 - 11:04
User Badges:

Since these APS are in the same subnet can't I just enable over the air provisioning? I know there is a vulnerability but this is a pretty much self contained building. The DNS trick did not work.

--Gary

Leo Laohoo Wed, 11/04/2009 - 14:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Gary,


Console into one of the LAPs, and in enable mode, use the command "config ap controller ip address ".

william.hostetler Wed, 11/04/2009 - 18:32
User Badges:

I would like to console in but they are mounted up in the ceiling. I tried installing older versions of 4 but only 18 APS showed up. When I upgraded back to 6. the 34 I did have came back so nothing lost there. I tried dhcp option 43, I have the controller listed in dns. I have OTAP enabled, I have Master controller enabled. Still nothing. The APS will not let me telnet or web in to them. I'm out of ideas. I may have to open a TAC to get this done.

thanks

Gary

Robert.N.Barrett_2 Wed, 11/04/2009 - 18:54
User Badges:
  • Bronze, 100 points or more

Can you:

1 - Try cold booting the troublesome APs?


2 - Try disabling Master Controller mode.


3 - Try to telnet/ssh into the AP's and issue the command that Leo posted

JASON BOYERS Wed, 11/04/2009 - 20:17
User Badges:

You mention the 1141s (presuming you mean the 1142s). Those are not supported prior to WLC 5.2, so they won't join a 4.x version of the WLC.

william.hostetler Thu, 11/05/2009 - 17:51
User Badges:

Yes I mean the 1142 and I know that they won't go below 5.2. So far I found that the contractor didn't have enough network jacks to plug all the APS into the network so that could be my problem on those. :)


The other thing I'm going to try tomorrow is just to hit the reset button on the AP, unplug its power and repower. I think that sets it back to its native state. Could be a simple fix.

Gary

william.hostetler Fri, 11/06/2009 - 12:02
User Badges:

In the end it ended up that the APs were not plugged into the network. Sorry if I had many people trying to figure this out. I do have one that is being cantankerous but it is only one.


thanks

Gary

william.hostetler Sat, 11/14/2009 - 11:15
User Badges:

In my latest building I have a contingent of aps that tried to join. I can use a web browser to get a web login page but it says it is not remote mode and won't let me. I tried rebooting the controller as the ones that didn't join say they have reached the maximum amount of tries.


It means I'm going to have to physically go there Monday morning.

Actions

This Discussion