Routing question

Answered Question
Oct 31st, 2009

Trying to gain internet access via another network....

My internet connection is via cable modem. First, is a cable modem that splits out my internet connection and telephones. The internet connection then goes to a Dlink router w/ wireless, etc. (and everything works good from here!).

I'm trying to get my Cisco lab connected to the internet via the Dlink router. This is because I don't want to disturb any of my other home connections via the working Cable/Dlink setup. I've setup fa0/1 port on my cisco router to dhcp and it successfully gets an address assigned (192.168.0.x) from the Dlink. I have 192.168.100.x assigned to fa0/0 supporting on my internal cisco lab network which then goes to a 3524 switch. I have other routers and pc's on the 192.168.100.x network that can successfully ping the DHCP assigned address, but can't ping any addresses on the internet (like 4.2.2.2). However, the main router being assinged dhcp address can ping internet addresses. How can I get all my cisco lab equipment to have internet access?

Any help will be very much appreciated.

Thanks,

Eric

I have this problem too.
0 votes
Correct Answer by marikakis about 7 years 1 month ago

Maybe this is a DNS issue. You ping using an IP address. What happens if you ping say www.cisco.com ? Make sure you have configured an appropriate DNS server for the PC's to use. I guess the appropriate device to forward the DNS requests is the Dlink router IP address 192.168.0.1 (if this router gets the public IP address from provider, it should take the provider DNS server address information as well). At least this kind of setup works in my home network.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Reza Sharifi Sat, 10/31/2009 - 12:24

Hi Eric,

Do you have a default route pointing to 192.168.0.x. subnet (towards the Dlink router)?

example:

ip route 0.0.0.0 0.0.0.0 172.16.0.1

HTH

Reza

Eric.Biggie Sat, 10/31/2009 - 13:49

Hi Reza,

Yes. Originally I had a static ip and default to:

ip route 0.0.0.0 0.0.0.0 192.168.0.0

then I changed the port to dhcp and modified the default route to:

ip route 0.0.0.0 0.0.0.0 fa0/1

either way, I still get the same results. When I try a traceroute ip from another router within my cisco lab to an internet address (4.2.2.2) it fails at 192.168.0.1 (my Dlink router). from a PC within my cisco lab, I can't even ping the fa0/1 port address, but I can from other routers. So I really don't know where the problem is, as I'm getting mixed test results.

Eric

marikakis Sat, 10/31/2009 - 14:16

The configuration of a static route only via an ethernet type interface (fa0/1 in your case) is not recommended for performance reasons. The configuration that uses a next-hop (such as 192.168.0.1) or both next-hop and outgoing interface is preferred.

There could be a problem with your return path from the internet. The default route helps to route traffic in the direction from the lab to the internet. You need a route in the Dlink router towards the cisco router for the internal subnet of the lab e.g. the Dlink equivalent of ip route 192.168.100.0 255.255.255.0 . The problem with this configuration is that the cisco router gets IP address via DHCP from Dlink instead of having a known static IP configured. Is this necessary?

Regarding the PC within your cisco lab, could you check if the PC has a default route towards the cisco router fa0/0 IP address?

Eric.Biggie Sat, 10/31/2009 - 15:06

Hi marikakis,

Thanks for your reply. Yes, I think the PC issue will be remedied once I add the default routes. I have no idea how to configure the Dlink's internal subnets to look towards my lab. This will take some more research on my part, but that makes sense, as I would have to that if it was a Cisco router too. I also noted a difference in the ping speeds (and sometimes not even 100%) when I changed the ip route to dhcp and port.

I'll try everything mentioned and let everyone know!

Thanks,

Eric

Reza Sharifi Sat, 10/31/2009 - 14:18

Eric,

All your routers and PCs are in the subnet (192.168.100/24) and interface fa0/0 is configures with 192.168.100.1/24 correct? The IP address of the fa0/1 is 192.168.0.1/24 correct? If this is the case and you are able to ping from the routers, but not your PCs, then may be you don't have the correct default gateway on your PCs. The switch in the middle is layer-2 only correct?

Reza

Eric.Biggie Sat, 10/31/2009 - 15:00

Hi Reza,

Yes, that's all correct. Also, I don't think I did default gateways on the PC's, so that makes sense now. The router (2801) connected to my Dlink fa0/1 has a 192.168.0.x/24 dhcp address (I guess I can change this back to static, and the default ip route back to ip vs. port). The fa0/0 port has ip 192.168.100.4/24. The switch is a 3524xl-pwr (you're correct, only layer 2). I also have more 2800's and some 2600's/3600's. All of them in the same network 192.168.100.x with different functions (it's a voice lab).

I really appreciate everyone's help. I just sqeezed by CCNA, so I could do the CCVP track since the voice/video world is my background. The routing/switching stuff just kills me sometimes....

Thanks again,

Eric

Reza Sharifi Sat, 10/31/2009 - 15:15

Eric,

You do not have to change 192.168.0.x/24 DHCP address. It should work the way it is now.

HTH

Reza

marikakis Sat, 10/31/2009 - 15:10

Your Dlink router will do some type of address translation (NAT) for the address assigned to the fa0/1 of the cisco router. If the cisco router also does NAT from fa0/0 (NAT inside) to fa0/1 (NAT outside), then the lab subnet becomes routable in the internet. In this case there will not be a problem with the return path from the internet because Dlink router will see only addresses connected to it (within subnet 192.168.0.x).

Eric.Biggie Sat, 10/31/2009 - 15:20

That was my first thought of what may have been the issue. Earlier today, I did setup NAT via SDM, but that didn't work so I removed it. And that's when I started troubleshooting and finding I had even more issues to resolve.

Thanks marikakis! I'll definately add NAT back into the 2801's config.

Eric

marikakis Sat, 10/31/2009 - 15:36

I just edited my previous post. The changes are not very vital. The point is that there are 2 problems here:

1. the private lab addresses to be seen as public for internet connectivity

2. the Dlink router to somehow know how to reach the internal lab subnet

If you do NAT on the cisco you kind of solve both issues, because the Dlink will see only addresses belonging to its connected subnet with the cisco router attached.

Eric.Biggie Sun, 11/01/2009 - 01:50

Hi marikakis,

I'm able to successfully ping IP addresses on the internet now, both on my PC's and routers within my Cisco Lab.

I set port fa0/1 (to the Dlink/internet source) to static, 192.168.0.179/24. My internal Cisco Lab network is on port fa0/0, 192.168.100.4/24. I enabled NAT on this router. I have IP route: 0.0.0.0 0.0.0.0 192.168.0.1.

I still can't access the internet on the PC's via Windows Explorer, but I can ping 4.2.2.2 from the PC's command prompt? I've made the PC's default gateway both 192.168.100.4 and 192.168.0.179

Either default gateway works, I can ping 4.2.2.2, but still nothing in Explorer? Maybe it's some kind of Microsoft issue?

Thanks again,

Eric

Correct Answer
marikakis Sun, 11/01/2009 - 03:18

Maybe this is a DNS issue. You ping using an IP address. What happens if you ping say www.cisco.com ? Make sure you have configured an appropriate DNS server for the PC's to use. I guess the appropriate device to forward the DNS requests is the Dlink router IP address 192.168.0.1 (if this router gets the public IP address from provider, it should take the provider DNS server address information as well). At least this kind of setup works in my home network.

Eric.Biggie Sun, 11/01/2009 - 04:02

Thanks marikakis,

Absolutely wonderful! Everything works now. All I had to do was add in the Dlink ip as the DNS server and explorer works now. An even bigger thanks for routing config and NAT idea.

And Thanks to Reza too!

Best,

Eric

marikakis Sun, 11/01/2009 - 04:15

That's great news! I always feel amazed when something finally works! Some take working technology for granted, but I usually find it unbelievable that so many components are put together and somehow they work! :-)

Actions

This Discussion